Download

(4.13) migrating the VR teleport settings from the VR template to an existing scene

Hi

I’m loving the VR template in 4.13, very nice.
I have teleport working fine in there, but if I select the 5 pawns in this scene, and migrate them to an existing scene, teleport doesnt work.

I’ve also copied over the config/DefaultInput.ini which seems to help a little (the hands now at least ‘grab’ when I press trigger) but something is stopping teleport from working.

any ideas?

best
Tom

Your inputs are probably not set up correctly.

Go to your Project > Engine > Input Settings of the VR Template project and export them. Then go to your new project and import those settings. This will overwrite any existing inputs you might have set up. You should now be good to go.

On another note, you don’t have to migrate the VR Template files. In your new project, in the Content Browser, click New and choose Feature or Content Pack and then choose the VR Template. it will import into your project.

Hi avinashlobo,

I followed your steps but I’m stuck. In the content browser I cannot find any “New” (do you mean the “Add new” menu?), neither “Feature” or “Content Pack”… Could you please be a little more specific, maybe sharing a screenshot?

Thank you

Andrea

He does. Click add new, then at the top add new feature or content pack. This window will open up

Then just select Virtual reality and that will add in the template for you.

hi,
i tried to migrate it too! It didn´t worked… I import and export the input too! But the Hands didn´t work. They are always laying on the ground.
It would be nice to watch with the htc-Vive and walk with an X-Box Controller. I didn´t get this working.

Did you migrate everything in the project?