Download

4.13.1 iOS Provision not found despite being valid

When I try to package my game for iOS I immediately get 2 errors that say.

“Provision not found. A provision is required for deploying your app to the device.”
“Signing key not found. The app could not be digitally signed, because the signing key is not configured.”

When I packaged last week with 4.13(before the 4.13.1 fix) I was able to package successfully, but after the update I have this problem.

So far I have re-downloaded the provision and re-verified the engine without success.

I have included my logs from the editor when I try to package. LogSourceControl: Attempting 'p4 fstat -Or /Volumes/Scratch/MPWJ/Game/Config/Def - Pastebin.com

I have exactly the same problem. Have tried everything and it still doesn’t work :-/ really hope Epic can fix this soon, since I need to release my game soon.

Same Issue - https://answers.unrealengine.com/questions/498731/ios10-deploy-fails.html
Using macOS Sierra and Xcode 8 -> iOS 10

Vasco, I don’t think we’re having the same issue. I cannot even get my build to start, as soon as I push packing I get a popup giving errors. My build won’t even start.

i get the same problem as path3tic

Error Provision not found. A provision is required for deploying your app to the device.
Error Signing key not found. The app could not be digitally signed, because the signing key is not configured.

Hi,

To fix this problem, I put the provision profile in the folder “MyProject”/Build/IOS/.

Then I can sign my package… (problems with simple launch)

Hope that can help someone.

I just tried this and it did not change anything for me. It looks like if you put your provision there UE just copies it to your system directory.

provisions and certificates are handled by Xcode not ue4 so the location shouldn’t matter

I’m just updating my xcode to ver 8 which in the update notes says

*code signing can now be automatic or manually configured

ill check this out later this evening and let you know if i get it working.

BTW has anyone had any issues with UE4 and the Sierra OS?

Ok Path3tic,

hi have an easy solution that works for me.
1, download your provisioning profile from the Apple Dev site (this appears in the ‘Downloads’ Folder)
2, In UE4, Project Settings, Platforms, iOS click the Box to ‘Import Provision’ manually and select the provision in the downloads folder
3, select the recently imported Provision manually with the tick box
4, Package your project

the signing certificates work ok

try this and let me know if it works for you

Hello everyone, the solution that Alan Webster lists does work, however you can put your downloaded provisions in the same place that XCode puts them, they just must be name correctly. In fact you can even rename the ones that xcode downloads to [projectname].mobileprovision or [projectname]_distro.mobileprovision if your signing for distribution. If I understand correctly this is an engine bug that should be fixed.

I tried but it does not work, the great thing about that with File-Package Project I have the license error, and if I do it from Project Launcher the procedure goes to fruition, however, loading the ipa of Application Loader itunes connect it gives me this error : ERROR ITMS-90167: “No .app bundles found in the package”

Path3tic, I had similar problems too.
I ended up rolling back to UE4.12.5… I’m not sure why yet, but 4.12.5 works without hitches.
And yes, on macOS Sierra and Xcode 8.

i found the same issue with the application loader app but it works and uploads fine using the application uploader built into xcode.
1 open xcode
2 file, open your packaged game .ipa
3 dropdown menu xcode, open developer tools, application uploader

I’ve been running into this issue as well and I believe the issue lies in UnrealBuildTool. It looks like UnrealBuildTool is looking through ~/Library/MobileDevice/Provisioning Profiles for a provisioning profile with the name of <Project Name>.mobileprovision but this is counter to how Xcode will manage provisioning profiles which uses a GUID to name provisioning profiles so certainly 0c3a4d92-d0e7-4312-9222-981b673292f9.mobileprovision will never equal MyProject.mobileprovision as an example. I can see two solutions to this past what has already been discussed here…

  • Get UBT to scan the ~/Library/MobileDevice/Provisioning Profiles folder and analyze each .mobileprovision file to see if contains the bundle ID specified in the project settings. The .mobileprovision files could be parsed using some of the methods discussed here http://stackoverflow.com/questions/6398364/parsing-mobileprovision-files-in-bash.
  • Rename or make a copy of the .mobileprovision file in the ~/Library/MobileDevice/Provisioning Profiles folder to your UE4 game name. From your iOS project settings in the editor you can find the GUID formatted .mobileprovision file that is valid for your project.

Copying the provisioning profile to <Project Dir>/Build/IOS worked for me as well though I like the idea best of having UBT do all the work and not conflicting with how Xcode does provisioning profile management.

No work for me

Hi, here is same problem when using distribution provisioning.

when updating engine 4.13 , there is some change with exception…

I found that and then
I propose this pull request.
https://github.com/EpicGames/UnrealEngine/pull/2889

I still do not know the exact cause (return wrong result with valid provisioning).
However I found a temporary solution that can be avoided.

FYI, this workaround does NOT work for me. The only thing that works for me with 4.13.1 is to use a wildcard for the application identifier in the provisioning profile.

Hi everyone,
https://answers.unrealengine.com/questions/511850/cannot-package-for-app-store-due-to-mobileprovisio.html
Answer of this question(thanks to NeoRob.gg) solved the problem for me. You need to have source code.

I try to pull request… instead of somebody.
Include answer hub content.
https://github.com/EpicGames/UnrealEngine/pull/2889

If there was wrong content,… leave some comment.

This problem (package distribution provision) still not fixed yet until 4.14, 4.15…

(release version engine)