4.13.1 iOS Provision not found despite being valid

It is not fixed at all for tvOS.

I have a post about the development cert problem and the distribution cert problem.

I’m currently having this problem with 4.14.1 - I tried importing manually inside UE4, where the certificate is marked as valid, but the provision says “Indentifier Not Matched”. If I try to import through the wizard, I get “Could not find file ‘Games\4.14\Engine\Build\IOS\UE4Game-Info.plist’.”

I see that in the project setting, that the game builds a plist. How do I create this missing file?

I found a solution but it’s weird, delete all provision files from ~/Library/MobileDevice/Provisioning Profiles/, then paste the provision file that your project need, open unreal and build, unreal automatically select that provision. Don’t open Project Settings it will create new provision and that cause conflicts.

I was able to work around this particular issue (finally), but unfortunately there are more problems that prevent submission.

I had the same problem and solution for me was:

  1. Update to the newest UE 4.14.3
  2. Clear old provision profiles and certificates
  3. Generate NEW provision profiles and certificates
  4. Download and install downloaded files
  5. Change date in the OS to tomorrow (due to the bug with timezones).
  6. Build

were u able to solve it for distributed version of certificate and provisional profile?

Yes, solution provided by me worked for my project.

I’m having this problem too. I’ve followed all the advice in the thread except altering the source, because I’m using an old MacBook Pro that would take weeks to build the engine (it takes over two hours to package an empty project with no starter content).

I wiped all my certs and profiles, started from scratch. Made sure they were trusted, imported them manually then set my date forward by one day. That last step made them light up green/valid finally. Then I get this:

Seriously unreal?!

To be crystal clear development builds have always worked but a distribution/ad-hoc build is not. This is what I need for testflight, right? Also I’m on 4.15.1.

Edit 2: I created a development build profile to trick it into progressing, verified in engine.ini that it would use the distribution credentials, then built. This worked. But when I went to upload it to testflight I got this:

So I guess it’s still a development build.

Is nobody able to distribute iOS games at the moment? Surely this is a world-breaking issue and has been in the engine for far too long.

I would try adding some development provisions and certificates at the same time (so you have development AND distribution provisions and certificates). A lot of the logic seems to be crossed in the check-if-i-can-even-do-this stage of packaging.

It’s even worse with tvOS.

I’ve tried that. It actually got me building… because it was only making a development build.

Then I did some tricky ****. I set it to use the distribution profiles, then saved and quit and made DefaultEngine.ini read only so that it was forced to retain the distribution profiles.

Then I loaded it up again, selected development profiles and asked it to package. It kicked off the build, but near the end it came back with the usual entitlements error.

I found the entitlements file inside the Intermediate folder and flipped get-task-whatever to false. Same error. I believe the problem is it doesn’t have entries for the default entitlements all distribution profiles have: game center, etc.

I tried unzipping the IPA to fix the entitlements and re-sign it with a distribution cert but I couldn’t unzip it.

Epic, where are you guys? This is the biggest dropped ball of the last four years.

I spent hours (literally, hours) trying various different things to get UE4 to package a Distribution Build for an older project that I just need to recompile with new SDKs and distribute an update.

This was super frustrating, as I am able to package fine on another iOS project; on that project during its development I used Development Profiles before using Distribution profiles. But on this older project that I just needed to recompile and repackage, I didn’t need a Development Profile, so I didn’t make one.

But that’s the problem. What worked for me was to have both a Development Provisioning Profile AND a Distribution Provisioning Profile copied into ~/Library/MobileDevice/ProvisioningProfiles. If you only have a Distribution Provision Profile you’ll get the errors every time.

i finally was able to made a shipping build . in case if anybody dont want to go through all those certificate deleting steps then use the fix :

I tried this solution but I can’t build with it. I got an ErrorCode=2…
With the original IPP and a develop provisioning profile as a dummy, it works for me.

Hello! Someone would tell me how to delete the provisions in mac. Thanks.

  • Shut down UE4
  • Open the Finder
  • Option-click the “Go” menu and select “Library” (it won’t show up unless you hold the Option key)
  • Go to ~/Library/MobileDevice/Provisioning Profiles/
  • Each provision is stored as a file with the .mobileprovision extension. Delete the one(s) you don’t want.