4.13.1 iOS Provision not found despite being valid

When I try to package my game for iOS I immediately get 2 errors that say.

“Provision not found. A provision is required for deploying your app to the device.”

“Signing key not found. The app could not be digitally signed, because the signing key is not configured.”

When I packaged last week with 4.13(before the 4.13.1 fix) I was able to package successfully, but after the update I have this problem.

So far I have re-downloaded the provision and re-verified the engine without success.

I have included my logs from the editor when I try to package.

Hi path3tic,

What system are you on, Mac or PC? In your Project Settings>iOS>are your certificates and provisons high-lighted green and do they say “valid?” Under Project Settings>Packaging: What are you packaging for; Development or Shipping? Make sure your Bundle Identifier matches what you have set up as an Apple Developer: you will need to sign into your Apple dev account to check this. Finally, if on a Mac, check your Certificates in your KeyChain Access window and be sure they are up to date. You may have to update your certificates and provisions.

Let me know if none of these resolve your issue; be sure to note what you tried and what you did not.


I am on a Mac

My certs and provisions do say “valid”. Furthermore, I have been able to packing with these and upload to the app store in the past few weeks successfully.

Neither development nor shipping work, although they both did in the past.

I double checked the bundle identifier from my dev account and they are the same.

I also opened the keychain access and my certificates are up to date.

Thanks for your help.

i have the same problem
Mac Book Pro
Osx 10.11.6
Xcode 8

Hello everyone,

I had this issue and got past it after doing the following. Hopefully it will work for you as well.

On mac, my provisioning profiles were marked as valid, but builds failed immediately after starting claiming that the provision was not found. After some frustration I noticed that their naming was different than on PC. The names given on mac was a long string of letters, numbers and some dashes while the PC version had the project name instead. Renaming them to fit the PC scheme, [projectname].mobileprovision or Distro_[projectname].mobileprovision, and placing them in ~ [projectfolder]/Build/IOS, made them appear alongside the other profiles in the editor after restarting it. Picking the renamed provisioning profiles made it possible to get past the problem.

In short, rename your profile files to [projectname].mobileprovision or Distro_[projectname].mobileprovision, and place them in ~ [projectfolder]/Build/IOS, then pick them as they appear in the editor after a restart.

I’m thinking the issue could be a change in how the profiles are handled. I’m sure it worked in older versions of the editor to just get the profiles through xcode or download and run them, adding them to the key chain. It seems that now the editor still sees the profiles in the key chain and recognizes that they are valid, but fail to access them when the time comes to build.

It looks like this was the answer. What a strange thing to be the problem. Thanks for you help.

I do wonder how this question was marked as resolved, because I did not mark your answer as correct because I had not tried it until now.

Hi , all i had to do is manually import the provision profiles using the ‘Import provision’ button and manually select to use the imported provision. Rather than mark the Question/problem as resolved with a workaround can you please log it as a bug to be fixed?


h marked it as resolved as SkyHigh has a temporary solution (really its a bug that needs reporting and fixing)

I have the exact same problem, but the workaround doesn’t fix it for me. Both the original provision and the renamed one (via the workaround) show up and say valid. Selecting either one makes no difference, I get the “Provision not found…” and “Signing key not found…” errors instantly.

This workaround didn’t work for me, either. :frowning:

Same problem here. Mac Pro 2013, OS X 10.11.6, Xcode 8.0, UE4.13.1 from the launcher.

I have tried the “rename and put in this folder and select it” workaround and the “manually import it and select it” work around. Neither changed anything. :frowning:

Hi ,

This is the instructions of how it worked for me

1, download your provisioning profile from the Apple Dev site (this appears in the ‘Downloads’ Folder)

2, In UE4, Project Settings, Platforms, iOS click the Box to ‘Import Provision’ manually and select the provision in the downloads folder

3, select the recently imported Provision manually with the tick box

4, Package your project

the signing certificates work ok

1, 2, and 3 are fine. I’m trying to launch on my AppleTV. With another project using 4.12.5 it works fine. With this project using 4.13.1, it just hits the two errors when I hit launch.

I removed the old provisions when I packaged, your mileage may vary, but I just thought I’d give my information.

How did you remove the old provisions? I don’t see any way to do it in the Editor, and the old provisions are not in the Build/IOS directory with the new one I put there as part of the workarounds.

I made a separate AnswerHub post with more information here: "Error Provision not found" even though the provision is present and valid in 4.13.1 - Programming & Scripting - Epic Developer Community Forums

You don’t appear to have the same problem as the this question, I’ll comment on your question

@path3tic I verified that the only profile in those locations is the one that I am trying to use. No luck. :frowning:

Let me clear up why those fail now. In Xcode 8, those are considered Managed Provisions and can not be used in the new manual signing mode, so they are being ignored during the detection of provisions during the final code sign pass by our system. The work around is as suspected to rename them or import the provision utilizing the editor. I’m working on a way to utilize them, but as they currently stand, they can’t be used in a manual sign and the current thought is to detect it as valid and then make a copy of the file without the id as the file name.