4.12p3 Extreme Editor Performance/Memory Issue w/ Planar Reflections

Hey guys,

This is difficult to explain so I created a video showing the problem. In the video I added an overlay with my GPU data view and Task Manager view so you can see exactly what is going on.

Adjusting any slider value on my ocean blueprint causes the editor to slow down by 80+% and start eating up RAM at an alarming rate (15gb in roughly 60 seconds) until I let go of the slider and wait ~5 sec for performance to return to normal.

I have not had any crashes yet, when it gets up to the 24gb RAM limit of my machine, Windows starts offloading it to compressed memory (or disk). Judging by the GPU data, it appears to be offloading VRAM to RAM once it hits my GTX980’s 4gb limit.

Click here to view the video

After trying to track down the culprit, I was able to reproduce this in a brand new project. Below are the steps to reproduce:

  1. Create new Blueprint First Person project (likely any type will work though)

  2. Go to Project Settings → Rendering and enable “Support Global clip plane for Planar Reflections” under the Optimizations section.

  3. Restart the editor

  4. once it loads open the “SkySphereBlueprint” and add a “Planar Reflection” component, then compile and go back to the main screen.

  5. With the SkySphere blueprint selected, try adjusting any of the sliders in the details panel, such as Cloud Opacity, and keep sliding it back and forth for 5+ seconds, you should see you VRAM and RAM usage spike and continue to grow, as well as editor performance drop significantly until you release the slider and wait another ~5 sec.

I’ll continue to look into this on my end, hope that is enough info to get you started.

Let me know if you need any other info (my DXDiag is below).

The video above is Preview 3, but this issue was also present in Preview 2 (did not use preview 1).

link text

Hey ,

Thanks for the notes and steps. This was easy enough to see the increase in the mem consumption. I’m syncing our latest internal build and will test there before submitting a ticket. That will be tomorrow morning at the earliest though.

I did notice while watching the memory consumption that mine did not happen as quickly as in 60 seconds, though it did climb quickly. Also, after PIE, loading a new/different level, or simply waiting I saw the memory usage drop back down. Do you notice the same on your end with the First Person Skysphere example?

I’ll post the results of my test in the morning with 4.13 and a ticket for the issue.

Thank you!

Hey ,

The blank FirstPerson project with planar reflections doesn’t eat up RAM as fast as my ocean project does, the issue is much more prevalent in the larger project.

The RAM usage does go back down a bit after a few seconds for me as well in the FP project, however in the ocean project it requires restarting the editor to clear it. It will sometimes drop down by a couple of gigabytes, but hasn’t returned to normal like it does in the FP project (both VRAM & RAM stay pretty steady). Instead It will go up to my 24gb limit and stay there. If I watch my task manager anything else I do in editor once at the limit will cause the Windows memory manager process to start writing the data to disk, but I try not to let it get that high.

Are there any logs, or console commands I can enable to produce a log with some data that would be useful? If you want to try out the project I’m using (~650mb) you can grab it here.

Thanks for looking into it ! Let me know if you need anything.

I was able to confirm it’s still happening in 4.13 (internal build) as well. I’ve submitted UE-30669 for this.

I’ll add the notes about your project and the link once I check it on my end. I didn’t see it hanging around with the FP template, but I’ll see what I get in your project.

Thanks for the clear repro and details. As always, you’re awesome! :slight_smile:

I was able to see the memory consumption not being released like it was in the FP Template. I’ve added some additional notes to the JIRA to cite this and your project as an example. Thanks!

Sounds good,.i’ts not currently affecting productivity on my end, it just seemed a bit extreme so I wanted to make sure you guys were aware of it.

Thanks for all your help !

Hey & All,

I seem to be plagued by this issue lately, currently trying to fine tune variable values using value sliders in the Details panel for a few large blueprints. Seems like every time I look up at the RAM count in the top right corner it’s up around 15-20gb for a project that shouldn’t ever go above 2gb otherwise. The editor doesn’t crash when it hits the 24gb limit (usually, did happen twice a while back) but the editor becomes really sluggish above 15gb ram used.

I was just wondering if there was any update on the status of this issue, has it been fixed in the latest github build?


EDIT: I’m currently using 4.12.5

No update to the ticket at the moment. The only thing added to the ticket was that this isn’t directly related to Planar Reflections. What looks like is happening is that when these sliders are scrubbed through their values the memory isn’t being flushed properly.

This can be reproduced with the BP_SkySphere as well by just scrubbing the slider values.

Yeah I meant to say that in my post, I was in my custom skydome with atmospheric fog in an otherwise blank level,no planar reflection actor in the scene.

Do you want me to rename the thread to fit the description better?

Also I noticed that scrubbing a slider has a very similar effect on the object count & memory as this Issue:

while scrubbing (with “show framerate and memory” enabled in Editor Preferences → Misc) the object count in the top right corner rapidly increases in the exact same way, and stops when you release it.

Just wanted to mention it in case the two are related.

Thanks ! =)