Download

4.12 Z-fighting alike artifacts

After switching to 4.12 I’ve got z-fighting alike artifacts on many objects.
They were ok in 4.11 so I assume it’s somehow related to the the GBuffer format changes
Can I somehow fix it, or switch to legacy GBuffer?

https://dl.dropboxusercontent.com/u/5836728/z-fighting.PNG

UPD: the glitch disappears if GBuffer format in project settings is set to force 16 bits per pixel, which is kinda weird, cause I don’t think I need all Channels in 16 bit, just the one that causes the artifacts

Are you sure you don’t actually have a z-fighting issue there?

Does this only happen in your project/level or do it happen in a blank project or new level in your project? I checked this in a new project just to be sure, but I didn’t see anything different after enabling the 16bits per pixel for the GBuffer.

The glitch is quite unstable. I can reproduce it on a new level in my project using the same meshes that have this glitch.
But I can’t reproduce it in a blank project.
If it helps: only some of “non-hermetic” meshes or meshes with open edges can have the glitch.

Same project, same mesh, new level, new simple material:

https://dl.dropboxusercontent.com/u/5836728/z-fighting3.PNG

I am absolutely sure that this is not a z-fighting issue. Exactly the same meshes acted well in 4.11, 4.10, 4.9, 4.8.

Objects on the left represent z-fighting issue, while object on the right show the strange glitch. Note the difference in channels

https://dl.dropboxusercontent.com/u/5836728/z-fighting4.PNG

UPD: It turned out that G-Buffer depth doesn’t affect much this bug.

Though it was removed by setting Early Z-pass to NONE.

The meshes doesn’t have double faces by mistake? I can get artifacts like that in Maya when I’m sloppy and get double faces by mistake.

For me it looks like you have a basic issue on the mesh… you should check your mesh in max, maya or whatever you are using…

Looks like a deformed tangent on a lightmap.

That is screaming z-fighting.

A face duplicated/extruded by accident and didn’t notice it is there?!
Happens all the time; I always run a mesh cleanup before exporting to UE, to make sure there isn’t any zeroed-area poly/vertices or non-manifold faces.

No, meshes do not have double faces. They were rendered ok in 4.11.
The issue is removed by setting Early Z-pass to NONE.

No, this is not z-fighting!!! They were rendered ok in 4.11.
The issue is removed by setting Early Z-pass to NONE.

I had a similar problem. I tried changing the Early Z-pass and forcing the gBuffer to 16 bit to no effect. I found changing the settings for my material texture made a difference, although I couldn’t tell you exactly which settings fixed it. Something to do with sRGB and the filter and the compression.