Download

4.12 VR Build

I have built my VR project out, but whenever I open the game it just shows black screen and closes. It works fine in the editor. In my level blueprint I have set console command to “Stereo On” which always worked in 4.11. Has there been made some changes to that on 4.12?

It does the same for a new project with only starter content :frowning:

However after trying to open it a couple of times it may randomly load. Has anyone else encountered this problem?

Same problem here with Oculus DK2. Can’t seem to find a solution. Best luck for me is to close the Oculus software, then launch my game. Oculus software will relaunch then sometime the game launches, sometimes the game shows black then closes. Odd thing is my load level does not call ‘stereo on’. It is just a menu screen that allows you to select with or without VR. That menu then directs you to another level that calls ‘stereo on’. So the problem is not with ‘stereo on’… but I have no idea what else it could be.

Yep, this is a thread i want to be subscribed to :)).
And as long as we are on the subject of the dk2, can anyone shed some light as to what we need to have installed on the computer so the VR game works for our clients or any other testers for that matter.

Good to hear that its not only me.

@dansuciu You need the Oculus software (https://www.oculus.com/en-us/setup/) and in settings->general allow for “Unknown Sources” that works for me.

[SOLVED]

27572f0a4e827055dd250bff2f9253b433597948.png

This work for me.

Press Alt+Enter to go fullscreen mode.

Work in Launch mode and Compiled game, but don’t work in standalone mode.

Cheers.

This issue is recognized by EPIC, it has been given a bug report #UE-31719 hopefully it will be fixed soon.

The only way to go into VR mode in 4.12+ is with “stereo on” in console or launching your game with -vr. CV1 has a proximity sensor and will not start rendering to HMD unless you have it on (or have your finger infront of proxmity sensor)

Make sure you have “enable unknown sources” in the oculus home app (under settings -> general)

Great to see both -vr and “stereo on” make it work, but is there a way to get VR to work in 4.12+ and have the primary monitor display a single image (instead of stereo?). Thanks!

This doesnt work in 4.12 anymore its working fine in 4.11. I am beginning to think that its only a DK2 problem… can other people confirm this? Create a blank project in 4.12 set it to “stereo on” and see what happens. DK2 and CV1.

Did you uninstall all previous SDK’s like Oculus 0.8 and then install oculus home(https://www.oculus.com/en-us/setup/)?

Yes I am running Oculus home 1.4…

sorry don’t know what to tell you, DK2/CV1 work for me and my Home PC (win10) and work pc (win 7) :-/ perhaps try to find the logs and see if you are getting errors in your UE4 logs? They are located in /saved/logs/

Having the same problem right now with 4.12.3. Had to disable SteamVR-Plugin. But performance is absolutely horrible, also the startup position of the player isn’t the same as before.

Since 4.12 packaged game for Vive closes right after launch if SteamVR service is not running. Don’t know about Oculus.

Same issue here. Can’t get a packaged game to run on the dk2…4.12.3. VR preview in editor works fine.

I can confirm the same behavior on my system. I’m running 64-bit Windows build, 4.12.2 with an Oculus Rift CV1. I never had this problem until I installed the SteamVR tool from within Steam, and disabled “Developer -> Start SteamVR when an application starts” from the SteamVR dropdown menu. It was getting annoying having the SteamVR pop-up every time I’d execute PIE or standalone mode of UE4.

I was experiencing the 5-second black screen followed by exit. This behavior went away when I re-enabled the SteamVR auto-start, or just start SteamVR manually.

Any news on this? I’ve got DK2 and I migrated a project to 4.12.5. Can’t even get it to work with VR preview in the editor. Project is working fine on 4.10.2 though… I specially migrated to 4.12.5 because of new planar reflections for mirrors :frowning: Any idea how to fix this? I’m even afraid of breaking older builds/projects after installing oculus desktop app (just have to config utility atm).