4.11p6 DX12 startup crash on existing project.

I believe it started up fine with DX12 in a previous 4.11 preview but I decided to spend the day porting a copy of my project to 4.11 and test for bugs.

Will crash at the end of project loading the editor. Just before the editor would appear, Unreal then crashes. I made an empty project and it loaded fine with the DX12 shortcut argument.

Included is my log files as well as my DXdiag. Logs

Hi Louie9588,

Are you able to open your project without the DX12 shortcut argument? Is the Crash Reporter present when it crashes? -If so, please cut and paste that into a text file and post it here. (Also, be sure to hit submit on the Crash Reporter pop up, if it is present during the crash.)

Also, you mentioned this project started up in a previous version of 4.11preview… Where were you porting this version of the project from. If you already had/have a version that opened in 4.11p4 or p5, you should be able to open it in 4.11p6. Please clarify.



I had to make a new copy of my 4.10 project files when I moved to 4.11 because my older 4.11 preview files were much older and missing a lot of stuff that I was working on in 4.10. I had already deleted the older 4.11 project files before I ran into this crash.

Without the DX12 shortcut argument it just launches as expected in 4.11p6. I had filled out the crash reporter before writing this post though. I will copy it here. Crash Report Text

Are you able to convert a blank 4.10 project to 4.11 with the DX12 shortcut argument?

Seems I can only replicate the crash with a copy of my 4.10 project launched in 4.11p6 with -DX12 argument.

I’ve tried conversions of blank C++ and Blueprint projects and have not seen this occur.

Edit: Forgot to note, I also tried a new copy of my 4.10 project to see if this crash still occurs with the “new” 4.10 to 4.11 copy. Same symptoms occur with that copy of my project.

Thanks for taking the time to try and reproduce the issue with blank C++ and Blueprint projects. Since the issue does not occur with these blank projects, then the issue would appear to be project specific and not a conflict with UE4 and DirectX 12. If you can send a dropbox or google drive link to me in a private message on our ****, I may be able to isolate the cause of the crash.

Will be a while if I do choose to upload my project. Though I narrowed down what causes the crash.

Before 4.11p6, in 4.10 I was building an AI blueprint for characters in my World Composition. So I had placed a Navmesh Bounds Volume in the example map. In 4.11p6 the editor crashes in DX12 mode if I have a navmesh volume in the current level.

I have no idea why the navmesh would cause this but if I remove the navmesh bounds and save the level. Reload 4.11 in DX12 mode, the editor will load fine in my default example level.

With a blank project, it also crashes if I have Navigation set as shown in the editor window in DX12 mode.

Edit: Opened editor in DX12 mode, placed nav bounds volume, built nav mesh, set nav mesh in Shown to be displayed, editor crashes.

Here are the steps I’ve followed to try and reproduce the issue:

  1. Open the editor in DX12 Mode
  2. Launch UE4.10
  3. Open new, Top Down blank project
  4. Press “P” to Show Navigation: Navigation area shows highlighted green
  5. Close project
  6. Launch UE4.11p6
  7. Open a copy of the Top Down Project created in UE4.10
  8. Press “P” to Show Navigation: Navigation area shows highlighted green
  9. Delete the Navmesh Volume
  10. Add a new Navmesh Volume and Build
  11. Press “P” to Show Navigation: Navigation area shows highlighted green
  12. Play in Editor:
    RESULTS: No crash

After reviewing these steps, please let me know if there is something I’m doing differently than you in order to reproduce the issue on our end. If so, please list new repro steps in the above format as thoroughly as possible.


Doesn’t matter if it is a 4.10 project used in 4.11. I’ve narrowed this issue to being just a 4.11 issue in itself on my desktop.

  1. Launch 4.11p6 in DX12
  2. Open new project.
  3. Add Navmesh Volume, Build
  4. Press P to show Navigation. Instead of showing navmesh, the editor crashes.

This only occurs with 4.11p6 in DX12 mode. No matter which project I’ve used. Navmeshes do not display in the viewport with DX12 mode in 4.11 without crashing the editor on my hardware.

Hey louie 9588,

After retesting, following your latest steps, I was able to reproduce the crash occurring when you preview the Nav mesh in DX12 mode and have entered the following bug report: JIRA [UE-27971]. When this issue has been fixed, we will notify you with an update to this post.

Thanks for bringing this to our attention and supplying all requested information so that we could reproduce the bug on our end.


Seems this issue has been resolved since 4.11p7. Navigation mesh now renders without crashing in DX12 mode.

Thanks for the update. I checked this on our machine and got the same results. I’ve updated the bug report JIRA [UE-27971] to reflect this but it has not been officially closed out as we are looking to find what caused this initially and what inadvertently fixed it.