[4.11p2] Tesselated Material does not Tesselate or Displace

As the title says, really. it doesn’t seem to be working no mater how hard I stare at the tesselation Multiplier.

It does render now though.

Hope it helps!

Hi Kettun,

Thank you taking the time to submit a report! I’ve submitted ticket UE-25334 for this to be investigated and addressed.

Tim

Hi Tim,

Has this been fixed lately? We also wanted to ask if Tessellation would be working with lightmap baking?

Thanks,

This has already been resolved internally. The fix should be in 4.11 preview 7 I believe, but I’ve not yet updated my binary version from the launcher due to some GDC stuff I’m working on.

I’ve not specifically tried it, but lightmaps should bake regardless, and if you use heavy tesselation it will likely distort what was baked though.

Thank you Tim, will look into this soonest!

Best wishes and thanks for the hard work.

Hello Tim,

I got to test this earlier and here are the results packed in a GIF:

As you can see “Movable” looks best and most accurate, “Static” is OK but useless in my case, “Stationary” being the most important looks inaccurate and has some flaws in finding shadow areas and/or working properly with the shader in softening out those shadows and absorption in this case. I do have a subsurface material there along with constant tessellation (without camera distance just for the test and baking). I tried various lightmap sizes but they all looked identical with just more sharpened shadows.

Any thoughts on this?

81814-tesselation_lightbake.gif

Many thanks in advance.

Oh just want to add that the above GIF was created in the latest: 4.11 Preview 7

I can’t debug any other kinds of things in this post that is not related to the original question of Tessellation not working properly. I’m really limited on time at the moment. If you want to post a new question in Rendering section of AnswerHub I can assign myself and hopefully have a look in a week or two, but as for tessellation working. It’s been fixed for 4.11 internally and will be int he final release it is still giving issue in 4.11 p7.

Hi Tim,

Sure thing I just wanted to post it since it was Tessellation related issue (granted coupled with rendering), so just wanted to share the issue since I thought you guys mentioned it was fixed but didn’t know or misread that its still ongoing fixes internally even after Pr 7. So I will wait for the final release and test this again.

Take care,

Thanks for understanding. If you post the lighting issue I’ll assign myself and have a look when I can. Thanks again!

Thank you Tim, here’s the new post

Best wishes and thanks again for all the hard work and keeping an eye out for the community!