[4.11 P8] Procedural Foliage Random Crashes

Been testing with 4.11 Preview 8 and quite often the procedural foliage tool will start generating and then crash. Gives no error/log but will build on next try or two.

Here are the summary logs, I got one crash that actually left some.


Hi ,

  • Does this occur in a clean, blank project with no additional content or is this limited to one project?
  • Does this occur with a specific asset or is it any asset?
  • Can you post the full crash logs here? They can be found at \Unreal Projects\PROJECTNAME\saved\logs. The file you have linked is the crash callstack.
  • What steps can I take to reproduce this error on my end?

Hi ,

We have not heard from you in several days. I am marking this as answered for tracking purposes. If you are still experiencing this error, please comment with the requested information.


Sorry I didn’t get the notification.

  1. Yes it occurs with a clean Project
  2. I tried 4 speedtree meshes
  3. I couldnt get any logs.
  4. Import a speedtree export, then add to the foliage generation. - I found anything over 6 steps with 6 seeds would crash.


  • Do your speedtree assets have tessellation on them?
  • What is the poly count of the assets you are using?
  • Can you post your dxdiag here so I can take a look?
  • Have you tried with non-speedtree assets? For instance, if you use one of the basic shapes in the editor, do you see the same crash?
  1. Speedtree Assets don’t have tesselation
  2. Varies from 3k to 20k
  3. I will PM You a DXDiag
  4. Admittedly nope.

Try using one of the basic shapes to see if you get the same crash.