Download

[4.11.1] Getting a black screen in every project when using VR preview

When trying to use the VR preview in 4.11.1 on my DK2, I just get a black screen in both my Rift and in the game play window. I have SDK 1.3 installed. Is anyone else experiencing this?
I get a black screen on every single one of my projects when trying to use the Rift. I’ve tried unplugging and plugging it back in and restarting my projects with the same result. All of my projects worked with the Rift before the 4.11.1 update.

  • UE 4.11.1
  • Oculus SDK 1.3 (Home)
  • DK2
  • 980ti with the latest drivers
  • Windows 10

Yes I too was getting this. For some reason I went to the character blueprint and enabled locked to HMD and then ran it for a second. then went back to blueprint and disabled it and it fixed my black screen problem.

I tried that and I’m still getting a black screen. I realized it may have been because “Unknown Sources” wasn’t enabled in Oculus Home, but upon enabling that I still have the exact same issue. Also, now games in Oculus Home aren’t even starting up. I’m starting to think there’s something wrong with my installation of Oculus Home, which would be really weird if that is the case because everything worked perfectly fine before installing 4.11.1. I’ll try reinstalling Oculus Home and seeing if that fixes the problem.

EDIT: Completely uninstalled the Oculus Home Runtime and reinstalled and I’m still getting the black screen. I really hope I’m not the only person experiencing this.

you may want to re-download your oculus home and install it. I have found sometimes the download has errors.

go to oculus home -> General -> check Unknown Sourcees

Like I said in my last post, I re-installed Oculus Home and have already enabled Unknown sources. Doing those things doesn’t change anything.

I am also just getting a black screen and tried everything recommended on this thread. I am stuck I run vr preview I get a black screen and the oculus setup grid room remains in my dk2 viewport.

I also get the same issue, can someone help me to fix it? thanks in advance.

If someone from the Unreal development team could chime in on this, that’d be fantastic, this is really effecting my work and it’d be great if the problem was at least acknowledged.