[4.10]Unable to Build to iOS in 4.10. But same Provision and Signing keys work in 4.9

Hello there,

This is the second self published iOS game. But the first on Unreal4.10

I have followed the process to add the provision, and certificates as advised. Both are Status Valid, and the Provision is check marked for distribution. As well as check marked on the left side. However, I’m getting this error whenever I try to build a Distribution iOS package(file or whatever it maybe called)

My builds in 4.9 do work just fine, with my other games. This is also a blueprint only project. As I have experience publishing in iOS I don’t believe this is user error.

Here is the error messages I’m receiving.

Any help would be greatly appreciated,

Thanks,
Brandon

Hello Bpop,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. When you say that your builds in 4.9 work fine, can you package out a clean project in 4.9?
  2. Could you try upgrading to 4.10.1 and let me know if this makes any difference?
  3. Is the project that you are trying to package one that has been updated from an older version of the engine or is it a clean 4.10 project?

Hi Rudy,

Here are the answers :slight_smile:

  1. I can create a full complete working build on 4.9. I have even submitted a project update to iOS, which was approved yesterday. This is with a heavily modified TappyChicken project with my own provisions and whatnot.

  2. Just updated and tried to package. Still the same issue :frowning:

  3. The project I’m trying to package is a clean mobile project using the same provisions that were tested on a 4.9 build and was working fine(note: not the same game mentioned in answer 1 however). I also tested on a 4.10 version of TappyChicken but still unable to build with my own provisions that worked in 4.9.

I also added a picture of my Project Settings>Playforms-iOS Provision and Certificate selection. Also be noted that whenever I restart Unreal 4.10.1 that the Certificate is deselected, if that helps at all.

Thanks for taking the time to ask the questions, I haven’t had much luck anywhere else :frowning:
-Brandon

I really want to hear from someone who got a blueprint project for the iOS to work. To see if it’s possible. I’m definitely not new to this but if it’s user error I would like to know. And if not if Epic is actually looking into it. :frowning:

Still nothing. Just finished my third game for iOS but because I did it in 4.10 I can’t package it :frowning: Sigh.

Hello Bpop,

Could you try packaging again and when you receive you errors could you open the output log and copy paste everything into a text document and attach that in your next reply?

Hi Rudy,

I’ve attached the file you requested :). Please note that the same provisions still work in 4.9.2. Would you like the log for that one as well? It feels like maybe 4.10 has a problem with the manual selection process? Anyways, here it is :).

Edit: I did some editing to remove my computers name from the output log.

Thanks
-Brandon

link text

After looking over the logs we were able to see that your project is having a hard time finding your previsions. Could you try setting up your previsions again to see if this solves your issue?

So it didn’t work :(. Here are the steps I took.

I removed the provisions manually. Deleting them from the user\AppData\Local\Apple Computer\MobileDevice\Provisioning Profiles.

Imported Provision inside the project while opened. Selected both certificate and provision and tried to build. Failed

Deleted provision manually.

Opened up iphonepackager.exe and did the steps to import the provision. And certificate. No green check marks tho. Hit ready for package. Opened up unreal and selected provision and certificate. Attempted to build. Failed.

Hi Bpop, just commenting to let you know I have packaged for both development and distubution and its working fine for me. Mac OS X Yosemite ue4.10.1

Although in 4.10.1 I have to instal and select the correct profile and certificate manually.

In previous engine versions the editor automaticity found my certificate and profile selected the correct one and hi lighted the text green.

So I attempted to run Unreal 4.10.2 on my MacBook, but since it is a really late model I’ve had a lot of trouble opening it up to work on my project. I did attempt to Import the provisions and Certificate. The provision worked but the certificate did not show up on the list. I’m not sure why it wouldnt. I am using an older version of Apple’s OS but I don’t think that would be the issue?

Please note I have already 2 certificates (iPhone Dev and Distribution) That is possibly interfering. I used these certificates previously with another game but no longer use them, but unable to remove them.

So I tried something new, I selected the wrong certificate. Then I tried to build… and Guess what… It worked… I’m not sure why I didn’t try that sooner but yep, selecting the wrong certificate allowed me to build the package… I’ll let you all know how it goes when I submit it.

So I was able to create a new build when picking the wrong certificate. I submitted it thru application loader and it uploaded just fine. Looking at the iOS Builds however it shows the build as invalid. So still broken :(.

The key idea I have now is that it could be that the previous two certificates I have are confusing the selection process. When selecting the right certificate it doesn’t work, and the build fails. But selecting the wrong certificate lets the build work, but is invalid build after submission.

I have provided a link to the setup wiki for certificates. Could you look over it and make sure that everything has been setup correctly? You may also want to try running through the steps again to insure that none were missed.

Link: https://docs.unrealengine.com/latest/INT/Platforms/iOS/QuickStart/3/index.html

Hello Rudy,

I went over the process again, even tho I’ve done it multiple times before. Still no luck :(.

Reminder tho, on 4.9.2 the same provisions and certificates work fine and were installed the the same way. I created a test project and uploaded it to Apple and was approved for beta (Just a test was not the actual game) with the same provisions and certificates. And that build was approved by Apple. However, the same Provisions and certificates do not let me complete a build on 4.10.1. I’ve tried everything possible.

So I believe, just because 4.9.2 works and 4.10.1 doesn’t. That the bug is engine based. Please note that I have 2 other, much older, certificates that when selected. It allows me to package a build that is considered invalid by apple. These 2 certificates, which I have no way to delete, may be mixing up 4.10.1. When I do select the correct certificate, that is when it fails to even package the game.

Could this possibly be escalated to a Trello Ticket? I am hearing from other people that this is happening to them. And the idea of transferring my project over to my Mac to try and fix this issue is not really a fix for the issue. Any help would be greatly appreciated but this definitely feels that 4.10.1 is the cause of the grief in this situation.

As I said previously, I have built and launched projects in previous versions just fine. The provisions and certificates I’m using in 4.10.1 do work in 4.9.2 but I do not have the free time to rebuild my entire game in 4.9.2. 4.10.1, and possibly future versions, will have this problem if it’s not taken seriously.

I understand that we must go thru the process of troubleshooting the issue to make sure it’s not User Error, and I appreciate all time being spent on handling this. However, I do know what I am doing. I have the most respect for Epic as I base my 7 years experience solely on how awesome you all at Epic are. But I really need to release this game. :frowning: Sorry for being so upfront.

I have a few more questions for you that will help clarify a few points.

  1. The project that you are trying to package has not been updated from an older version of the engine?
  2. You have tried packaging for both shipping and developing?
  3. You have gotten another clean project (created in 4.10.1) to package with the current certificate and previsions?
  4. When you say that you were able to package with your older certificates was this tested in 4.9 or 4.10?
  5. Would it be possible for you to provide a project that you are unable to package so that I could take a closer look?

Thanks for the response :slight_smile: Sorry for being all frustrating. Here are the answers.

  1. The project has not been updated from a previous version, I created the project in 4.10.0. But I do have the 4.10.1 update.

  2. Yes, still not building.

  3. I created a clean project in 4.10.1 to test out the certificate and provisions. The same error occurs.

  4. In 4.9.2 I am able to package with the new certificates, and provisions, created for this game in a clean project.

  5. I am able but would need a secure way to send it to you.

Thank you for the response.
-Brandon

Could you try removing your old certificates to make sure that this is not causing the issue that you are experiencing?

Remove Certificate on Windows:

  1. Open Certificate Manager by clicking the Start button, typing certmgr.msc into the Search box, and then pressing ENTER.‌
  2. Select Personal > Certificates
  3. Delete any "iPhone Developer:* " certificates

Remove Mobile Provisions on Windows:

  1. Go to C:\Users\first.last\AppData\Local\Apple Computer\MobileDevice\Provisioning Profiles
  2. Delete all .mobileprovision files