[4.10]Unable to Build to iOS in 4.10. But same Provision and Signing keys work in 4.9

Hi again,

In 4.10.1: I removed all the older certificates and provisions as advised. Reinstalled them both in iphone packager, this failed to package. I then installed it directly in Unreal 4.10 after deleting both certificates and provisions again. That packaging also failed.

In 4.11 Preview: I attempted to a package a clean project, and a copy of my game, and it still had the same error.The packaging failed.

In 4.9.2 I attempted to build with the certificates and provisions. This worked and I was able to package the clean project with the same Certificates and Provisions that failed in both 4.10 and 4.11.

Thank you for your time spent on this issue,


After doing a bit more digging I was able to find a similar issue dealing with “cook on the fly” and I was wondering if you are using the cook on the fly feature?

How I’m cooking is thru File>Package Project>iOS. I’m not seeing any option in the settings that say “cook on the fly”. Could you clarify where that could be to turn it off? Or if I should try another way to cook?

Still no luck?

After doing some more digging I was able to find a similar issue that has been answered by a developer. This is the issue that was mentioned in a forum post that you were a part of. I know that you have taken a look at the post at the link below. I believe this is the same issue that you are experiencing. Please visit the original post (linked below) for future updates on this issue.

Link : iTunes Connect invalid binary - Mobile - Epic Developer Community Forums

Make it a great day

This seems like the same issue.

However, I would like to mention my 4.9 Build (Update for previous game) was accepted just fine in December by Apple. Built on my PC. So just to clarify, 4.10 is the problem. And 4.11 didn’t fix the problem. If you make in 4.9 your build will be accepted. Even tho it seems Epic has been saying otherwise. Which is concerning…

I have the same exact issue with 4.11 preview 7. I can remote build from PC->Mac just fine with developer provisions/certs but as soon as I import the distribution provision/cert it says they are valid but do not light up green. As soon as I try to package I get the 2 warnings you mentioned at the beginning of the post. I do not understand what is going on but need some way to get this working as we’ve been trying to release for the past week.

If I HAVE to manually do it on the mac what is the easiest solution to get my project over there? Also, can I just use the UE4 installer or do I need to update the GitHub source on the mac?

(sidenote) At what point does the iPhonePackager get the -distribution argument? It looks like it fails all the time because it is trying to verify it is a debug provision when in fact it is a distribution provision.