4.10 regression, client side navmesh seems broken

Updating to 4.10 seems to have broken client side navigation.
On any other player than server we get dreaded “NAVIGATION MESH MUST BE REBUILT” white overlay.

This started happening after converting our project to 4.10 but seems to be reproducible simply by using top down template and ticking the “Allow client side navigation” box in project settings.

I tentatively tried to trace it through c++ code in a debugger but I’m not familiar with engine’s source. It seems that client creates a second recast navmesh instance in UNavigationSystem::SpawnMissingNavigationData while loading map but does not populate it from archive (Serialize not called on mesh).

Thanks !

Hi carnaval,

Thanks for report! I can confirm that I’m getting same message in 4.10.0, and I’ve created a bug report to track issue (UE-24188). I’ll post here when I see any update on it.

I’ll also mention that it doesn’t appear to occur in our internal main branch, which should become 4.11. It’s possible that whatever change was made in 4.10 to cause this was not brought over to Main, and it might not be a problem moving forward. There does appear to be a separate issue with Simple Move To used in Top Down project on Client (it’s not supported), but otherwise nav mesh appears to function correctly. Hopefully this bug report will prevent that change from being moved to 4.11, or a fix will be made before 4.11 release.

If you continue to see any problems with this after next full engine release, please update this post. Thanks!

Thanks for quick update. We’ll stay on 4.9 for now. (yep path following is custom and only using FindPathXXX functions, I don’t think SimpleMoveTo ever worked using client side navmesh)

Cheers :slight_smile: