4.10 installation failed with error R-1638

Installing 4.10 fails at Prerequisites stage with error "The necessary prerequisites have failed to install. Error Code R-1638

Hey tattries-

Are you installing the editor from the Epic Games Launcher or from source code? If you are using source code did this error occur when running Setup.bat or GenerateProjectFiles.bat? It may be that your version of Windows is not updated to the latest patch, can you try running Windows Update and then attempt to install again?



Installation is from the Epic Games Launcher. I did check that windows update is updated but still failed. Note: the OS version is build 10586 (threshold 2).

did you just install visual studio 2015? if so the typical install is not enough. You also need the toolchain which is outlined in this post

Did include the install steps for Visual Studio , the problem might be I upgraded Visual Studio 2015 to Update 1.

I’m also experiencing this issue. I’m attempting to install through the Epic Games Launcher and also am updated to Visual Studio 2015 Update 1.

If I attempt to install the prerequisites directly through the exe file and not through Epic Games Launcher I get a log file with the following at the end of it:

[2E70:26AC][2015-11-11T17:04:34]i301: Applying execute package: VC140_X86, action: Install, path: C:\ProgramData\Package Cache\BFB74E498C44D3A103CA3AA2831763FB417134D1\vcredist_x86.exe, arguments: '"C:\ProgramData\Package Cache\BFB74E498C44D3A103CA3AA2831763FB417134D1\vcredist_x86.exe" /quiet /norestart'
[2E70:26AC][2015-11-11T17:04:35]e000: Error 0x80070666: Process returned error: 0x666
[2E70:26AC][2015-11-11T17:04:35]e000: Error 0x80070666: Failed to execute EXE package.
[29D0:2B50][2015-11-11T17:04:35]e000: Error 0x80070666: Failed to configure per-machine EXE package.
[29D0:2B50][2015-11-11T17:04:35]i319: Applied execute package: VC140_X86, result: 0x80070666, restart: None
[29D0:2B50][2015-11-11T17:04:35]e000: Error 0x80070666: Failed to execute EXE package.
[2E70:26AC][2015-11-11T17:04:35]i351: Removing cached package: VC140_X86, from path: C:\ProgramData\Package Cache\BFB74E498C44D3A103CA3AA2831763FB417134D1\
[2E70:26AC][2015-11-11T17:04:35]i330: Removed bundle dependency provider: {31b49e1e-03f8-4a04-8faa-f6476d8fad02}
[2E70:26AC][2015-11-11T17:04:35]i352: Removing cached bundle: {31b49e1e-03f8-4a04-8faa-f6476d8fad02}, from path: C:\ProgramData\Package Cache\{31b49e1e-03f8-4a04-8faa-f6476d8fad02}\
[29D0:2B50][2015-11-11T17:04:35]i399: Apply complete, result: 0x80070666, restart: None, ba requested restart:  No

For reference if it also helps in any way:

Windows 10 64bit (fully updated)
Visual Studio 2015 Update 1 with every option installed/updated
Visual Studio 2013 installed but unused

To add this the UE4 Prequesties installer when run as stand-alone and not through Epic Games Launcher gives the following error:

“0x80070666 - Another version of this product is already installed. Installation of this version cannot continue.”

You can try installing the toolchain , and I even recommend installing this Download Visual C++ Redistributable for Visual Studio 2015 from Official Microsoft Download Center Make sure you have updated Windows to the latest version.If all doesn’t work , maybe you can try to reinstall Visual Studio 2015 , without Update 1 if it is possible.Let me know if this works or not

Thanks for the inputs, I was able to install 4.10 by doing the following:

  • uninstall the VS 2015 C++ redistributable x64 and x86,
  • ran the prerequisites directly through the exe ( as suggested by Alters)
  • ran Epic Games Launcher which successfully installed 4.10
  • finally reinstalled VS 2015 update1 to reinstall the C++ common components.

Appears to have work so far.

I had the same issue and uninstalling the VS 2015 C++ redist did the job, after that I just ran the install for 4.10 through the Epic Games launcher and it worked.
I had an additional thing happen though after that, an install for .NET 3.5 appeared on screen (which failed) though apparently 4.10 installed correctly at that point.

I manually went and installed .NET 3.5 after the fact anyway (just in case).

Sounds like the 4.10 installer needs to be updated to continue installation if the pre-requisites are already there.
It’s funny (and annoying) to have an install fail because pre-requisites already exist.

Can anybody tell me where the prerequisites installer is? Because I didn’t understand Step 2 in tattries’ answer.Please shorty explain the second step to me.

I think you can ignore step 2 . Just uninstall both the VS 2015 C++ redistributable x64 and x86 and then rerun the Epic Games Launcher to install 4.10. that would work.

I tried uninstalling both the redistributables and then open Epic Games Launcher , but it crashed again.

The prerequisites installer I ran was somewhere in the “programs files\epic games” folder, but I can’t seem to find it now. Might have been removed after install of 4.10…sorry give exact location.

I found it, It is in C:\Program Files\Epic Games\4.10\Engine\Extras\Redist\en-us
But it did not fix the problem

Hi KoushikK,

I just wanted to check in and see if you were able to get everything working. If not, could you please provide more details about exactly what you are doing and what error you are seeing?

removing the VS 2015 C++ redist did the job. I just uninstalled them both and hit resume and it installed perfectly.

Thank you!

I’m trying to install the 4.10.1 using the Epic Launcher and i keep getting the R-1638 error even after trying all the above steps.

Same here. Tried uninstalling the redistributables, even the launcher, but still fails after several tries (and computer restarts)

Did u install 4.11 before ?

If yes, you may find help in my post here : We need clear guidelines to solve 4.10 installation errors - Getting Started & Setup - Epic Developer Community Forums