Download

4.10 app doesn't run - black screen

So I followed the documentation and built/deployed Gear VR project (default scene).

The only significant differences between docs and my results were extra .bat file in the build folder ( NoOBBInstall.bat, which I didn’t run ) and whooping ~3.5 hrs of build time o.O (hell, Unity builds much faster for Android)

Here is my log: http://pastebin.com/mUL3AKXp

When I ran the app from the phone, it asked me to insert phone into Gear VR, which I did. All I got was back screen. Nothing worked, not even back button.

What did I do wrong? (except going with ASTC compression, since that’s what Oculus recommends)

So, I tried building with ETC2, after I built lighting and geometry. It went much faster than with ASTC.

I still get that black screen when inserting it into Gear VR.

So I tried running that NoOBBInstall.bat file for deployment. When I inserted phone into Gear VR, I saw jumbled white screen (looked like a stretched top/down stereo in mono) with UE4 logo, download progress bar and Pause Download button. Nothing else was happening.

I am not really sure what to think. Either docs are not complete and something critical isn’t explained, or Epic needs to provide a scene that can be built and deployed per docs to Gear VR without any hassles, just like it happens with Oculus Unity Utils with Oculus docs.

Ook, got some progress - apparently I turned off Paper2D plugin. After I turned it back on, and rebuilt, I am getting the following message when in Gear VR (the app asks me to insert the device into Gear VR, which I did, and black room with blue floor loaded):

Thread priority security exception. Please make sure APK is signed.

As I mentioned, I already have 2 OSIG files where they belong.

I’d love some clarification here as well. I am just getting a black screen as well when I try to launch my app.

Motor, could you share what android settings you have? You seem to be further than me since you go something to launch.

I had this issue last night and it turned out that the default map in my project settings was set incorrectly. I would double check that before looking for any other solutions.

There ya go: https://www.youtube.com/watch?v=NVvYGJ_rnko

The main thing was to place OSIG file into proper folder.