Download

4.1.1 hotfix update now available

UPDATE: 5-12-2014
The optional 4.1.1 update is now available to all, click on the update install option on the launcher. Thank you!

Hi everyone!

4.1.1 Update Fixes:

  •      Fixed shader material instances not being saved to DDC, causing many shaders to be rebuilt when loading the editor.
    
  •      Fixed crash on iOS/Android reading blueprint assets with certain unaligned opcodes.
    
  •      Fixed handling of volume buttons on Android.
    
  •      Fixed sporadic crash caused by race condition in the XboxOne texture compressor.
    
  •      Fixed engine compiling more shaders than necessary in the material editor.
    
  •      Fixed severe performance regression for some GPU combos on Windows, where the engine would fall back to the software renderer.
    
  •      Fixed crash when pressing the news feed refresh button multiple times.
    
  •      Updated .gitignore to include SDL2
    
  •      Addressed an analytics error
    

If you previously opted-in for the preview of 4.1.1 Hotfix make sure that you remove the tag -applabel=Production-Preview your launcher shortcut.

For Source users on GitHub with a currently active subscription, you can grab the latest 4.1.1 version from the following link (be sure to be logged into your GitHub account for the link to work): https://github.com/EpicGames/UnrealEngine/releases/tag/4.1.1-release

Please be sure to let us know if you experience any issues with this update.

Thanks!

Yup, works good! Shaders compile much less frequently, it’s so much easier to iterate with materials :slight_smile: I’ll post again if I notice any major crashes/problems. But so far, so good! :smiley:

Ditto that. Quite a relief to be able to fiddle with shaders again. Good job sorting that out!

I noticed the software renderer sometimes triggers when you’re trying to paste HEX codes for the hue of lighting in a blueprint-lamp’s preferences, and the window’s width can fall off the screen ad infinitum…

Epic may wish to repro that, if they haven’t already done so, before rolling out 4.1.1.

UPDATE: 5-8-2014
We have rolled out an additional update to the 4.1.1 preview which addresses an analytics error. This is an optional update, click on the update install option on the launcher. Thank you!

Hi Hyncharas,

Please post this to the answerhub at http://answers.unrealengine.com so we can track and investigate this report. Thank you and have a great day!

Where is the launcher shortcut? I know what I have to plug in, but where is it?

hi, I am a new guy
I want to know what does it mean “- Updated .gitignore to include SDL2”?
Does it mean in 4.1.1 we can’t use SDL2 with UE4?

Very nice. Seems much more stable and not compiling shaders every 5 minutes is glorious.

No it doesn’t, if you’re using the launcher version it’s irrelevant.

is 4.1.1 available on the mac and if so where can I download it. I don’t see an option in the launcher.

Hi dustintinkler,

You have to enter the parameter using Terminal. After typing the command line in, then when you open the editor you should see a line that says “update launcher”, selecting this will allow you to upgrade to the 4.1.1 preview.

Go to finder>applications>utilities>terminal and in the terminal.app type this in (with the spaces included!):

open -n /Applications/Unreal\ Engine.app --args -applabel=Production.Preview

Thank you and have a great day!

Is 4.2 preview build up? Because a friend is having errors compiling it. If so, please correct it, so I may download it and use it. Thanks.

Hi DarkInfiktrator,

Are you referring to the 4.1.1 preview build or the 4.2 master build on github?

I can’t find the shortcut. I only have a “verify install” option. Is there some way you can re upload the update? The file you posted is no longer online and there is no way for me to fix this. Thank you.

I tried using the -applabel=Production-Preview with the shortcut for the launcher but that doesn’t work for me.
That’s all you are supposed to do right? You right click on the short cut and then paste in the line after it? This doesn’t work for me.

Hi lerygen,

Make sure you set it up like this:

ShortcutParameter.jpg&d=1399670794

Of course, you have to close and restart the launcher after making the change.

ah wow finally. for some reason when I tried it the first two times it didn’t work. This definitely works though eventually if not the first time! Thank you very much.

Just confirming, is the Update Install button mentioned here is the same as Verify Install that I see in my Launcher?

Thanks!!!

This is awesome and is installing just fine. While I’m glad that the shader compiling issue is fixed, the macros and interfaces crashing the editor in 4.1 if you try to open them or create new ones is still a huge game breaker right now. Has that been fixed in this update?

Is there anything inside the editor we need to change to get faster shader compiling? I’m still getting up to 1000 whatever the counter shows just by changing the colour and applying it to my mesh; ue 4.02 was much faster.