3dWidget Web Browser not working in Gear VR

I am trying to use the [Web Browser][1] in a [3D Widget][2] in the World (so, not in the HUD).

This is what I’ve done, pretty simple and straightforward:

after I put it in an empty Actor Blueprint, this is working well on both Viewport:

and Mobile Preview (sorry I didn’t wait for all shaders to compile, but the widget is in its place):

unfortunately once I package for ETC2, it doesn’t work on Gear VR, see this screenshot:

nice, uh? It seems as if it stucks to my HUD screen.

I have to admit, anyway, that I photoshopped the screenshot above. Yes, because when I tried screenshotting it with the native screenshot function, what I got was this:

So I actually 'shopped in the screenshot the white rectangle that I was seeing in the device.

Notice that I tested other 3d Widgets and they are working as expected (in fact, you can see the blue rectangle in its place).

Of course please don’t mind the error message and the blank page, the link was not working at the time, but the blank page is where it should be anyway.

I am not sure if this is in any way related to [other problems like the one signaled by motorsep][8], and I tried to solve it disabling depth test like suggested [here][9] and [here][10], but it didn’t worked.

Did you enable Internet in your Android Permissions?
Look at your Android project settings, scroll down til you see extra permissions/manifest, etc.

You have to enable internet separately.

No I did not - but that’s not the problem, I can see the website quite well (once I set the server up&running…), and updating realtime; it works even on Gear VR. My problem is that I’m seeing the webpage stuck to my face instead of stuck to a wall.

haruna, are you sure that I need to manually add the permission in project settings? If I package it with no other permissions and I open the Android Manifest in the final apk (try it yourself :wink: ), I can see there are several permissions that I didn’t add: android.permission.INTERNET, android.permission.WRITE_EXTERNAL_STORAGE, android.permission.ACCESS_NETWORK_STATE, … I don’t know why, but maybe they are added by default because I checked Configure the AndroidManifest for deployment to GearVR, in the Project settings, right below the Extra Permission Settings that you pointed out. I think it might be that those settings are useful only for ordinary Android applications

I saw the “failed to load URL” error in the upper left corner of one of the images hence I thought it was an internet permissions issue.

I stopped working on GearVR and switched over to GoogleVR and I had to add internet permissions when I wanted to stream video for that app.

Sorry mate, free bump!

Hello ocramot,

I was able to reproduce this issue on our end. I have written up a report ( UE-32740) and I have submitted it to the developers for further consideration. I will provide updates with any pertinent information as it becomes available. Thank you for your time and information.

Make it a great day

Thank YOU for your time and help. I hope you will be able to fix this soon and keep it up with your awesome work.

While you’re at it, would you please have a look at these two other bugs? :slight_smile:


I think they might be related (or at least, it’s related that I’m seeing the webpage in an angle of the screen instead of the center of the screen).