Download

3dsMax Vray to UE4 via Datasmith = lights too bright

Starting to dabble with UE4 since they announced Datasmith. First main problem is that it comes into UE4 way too bright. Anyone know why? Can do a PostProcessVolume to get exposure down, but would like to figure out everything the right way. Also, all my SelfIlluminated maps come in dark or black.

Thanks - Chris

UE4 - 4.19
3dsMax 2016

I’d also like a solution to this. I have to dial lights back after import from something like 30000000 back to 10 for intensity… Thanks!

I get the same issue with Corona.

I think you’ll need to divide the intensity by 10000 or something. I think the problem is they made a mistake with the physical light intensity unit. At least when I tested it a while ago. They seem to be using the old “Unitless” value as “Candela”.

Report Unreal Studio bugs here: https://unrealstudiohelp.epicgames.com/s/article/How-do-I-report-a-bug

Anyone still having this issue?
I am importing a scene from Max to unreal via datasmith, which uses corona lights and daylight system
Each imported corona light is paired with a DatasmithAreaLight actor and i am not sure why + the intensity is far too bright

I am still having this issue as of 8/13/2018. Using Max 2019 w/ Unreal 4.20 and latest Datasmith version as of today.

any updates on this topic?

We will need to check again. In theory, a high intensity might not be wrong - that goes hand in hand with exposure which in turn can be way off. So either the intensity of the light is too high, or the exposure settings is too low. But its true that this issue is brought up often and we have to revisit how its done.

Has anyone tested the above comment? (viewing through scene cams?) As this did not resolve the issue for me …

You can adjust EV100 value to 11 or 12. See if the exposure is normal?

I also met a similar problem

I had this issue when I was working with V-Ray imported lights. My workflow to this was just to build the lighting and see how it looked baked (if you used baked lighting). If this still wasn’t correct, I’d amend the views in Unreal and just have some separate values. Not sure if you’re using the units on the lights to help you achieve real lighting or arbitrary values.

Also here, when importing from 3d max vray lights. All area lights have insane intensities :confused:

well I have the same trouble with vray lights, and theres no sense, but lower intensity to 1 or 0 changes nothing

I’m having the same problem still with 4.21. None of the intensity settings on the Light BP have any effect. It also imports a second skysphere, but even after deleting this the lights are way too bright. We have had to recreate all our lights in UE.

I thought they would fix this in 4.21. Oh boy…

Any news about this issue? I’m still having the same issue when importing with datasmith, but even if I uncheck the visible toggle in the world outliner tab, my object still seem super overexposed, any ideas?

Hi all.

This issue has been fixed internally, but not in time for the 4.21 release; and the change cannot be implemented in hotfixes. This fix will be included in the future 4.22 release.

Cheers

I have same issue, but i found what cause this effect in my chase. 1. Use candelas or unitless In 3ds max 2. In detail panel datasmith light bp, select point light component and in detail panel uncheck “Use IES Intensity”
[SPOILER]

[/SPOILER]