Download

3ds Max (Nvidia Apex Cloth) Mesh Disappears When Rendering

I’m very new to this, so any help would be great. I’m expermenting with some game models to try and get the physics and lighting to mimic that of the game it’s from.

I’m only having an issue with this file and other files I export from Blender, when I follow the tutorials and use the tutorial files everything works fine.

I would really like to find out why this file has an issue, because I have many other files that are of similar formats that I wanted to test apex cloth sims with.

My file was an XPS, imported to blender and exported to FBX and cleaned up and being worked on in 3dsMax. When I try to use the Apex Cloth Modifier on parts of this mesh it goes a little crazy. It instantly crumples up into a ball that freaks out on the floor (You can see it if you look closely in the second image).

The rig is good, and I’ve tested the bones and they move the proper parts of the mesh.

Here’s the result I get:

Here is the MAX file that I’m using:
https://www.sendspace.com/file/o9ejqb

Any help would be AMAZING. Thanks!

Here’s a quick test I did with JUST the belt and removed every other bone and I had the same results

(After running the the sim, it instantly crumples up into a ball)

And I noticed someone else was having this problem too (But he was never able to find a solution)

And if I merge one of the .max tutorial scenes over the file I have, and that file run fine inside of my current scene THAT mesh runs fine. What could be causing this?

This might be what you are looking for, straight from the Nvidia Dev forums
https://devtalk.nvidia.com/default/topic/526257/apex/apex-cloth-disappears-in-udk/

There is also this, are your units in meters then going to cm in Unreal? Apex needs to go cm to cm.
I always set Max’s base units to cm, that matches Unreal’s.

So could be a bug or the units are mismatched.

Thanks for the reply! I was able to figure this one out.

Max wanted to convert the FBX file to inches, (It was set to automatic) which was causing this. To match with unreal I tried settings the import the CM, and MM but this didn’t work for me.

I just had to make sure the scale of the file did not change and I used the same measurement (Which in the case was Meters) keeping the scale at 1.0 when importing. This 100% fixed this, I just manually scaled the model on import.

Good to know man! :smiley: