Download

3D Widget With Depth Pass Disabled Still Being Occluded

I disabled the depth pass on this material ‘/EngineContent/EngineMaterials/Widget3DPassThrough’, which disables the depth pass on all translucent 3D widgets. This works and it doesn’t. Depending on the angle, objects may or may not occlude the 3D widget. The images below show what I’m talking about.

Not Occluded
[screenshot]http://i.imgur.com/rAygIxp.png[/screenshot]
[screenshot]http://i.imgur.com/dMkvuYX.png[/screenshot]

Occluded
[screenshot]http://i.imgur.com/COpfALu.png[/screenshot]

Things just got weirder. The image below was taken in the same exact spot as the Occluded image above. The only difference between the two is that the occluded one was taken using Print Screen(what I see) and the non occluded image below was taken using the HighResShot console command.

Not Occluded
[screenshot]http://i.imgur.com/wlGGPJu.png[/screenshot]

@drb1992

Could you please file this as bug report on AnswerHub ?

Also, what version of the engine are you using ? 4.13 should have an option to disable depth pass per widget, so you no longer have to use this hack.

That is good to hear about 4.13. This was within 4.12. I created a bug report.

If you are using this as a regular static mesh in the world you may have to increase the bound scale to be huge.