3D widget nearest neighbor filtering?

I’m not sure if I am missing something but I cannot get my 3d widgets in world space to use the nearest neighbor filtering rule.

I have tried setting the render target’s filtering to “Nearest” using blueprints but this seems to have no effect on the rendering at all. I have all AA turned off. (It’s a pixel art game so AA isn’t really needed)

The widget looks perfectly crisp int he umg editor but once in world it looks filtered.