Download

3 Questions - My Normal map, my lighting, my texture resolution

Hi,

I recently finished texturing a little character in substance. I imported the .subsar file using the unreal plugin. Everything looks great (except for these 3 problems).

First. I designed the character to use 1 single 4k texture sheet, but even after exporting 4k textures from substance into the .subsar, they come in as 2k textures to unreal. I didn’t find any options to edit the import size in the plugin.

Lastly, For the “holes” I would like to keep those absolutely black, as if the lighting doesn’t effect those parts of the mesh. The AO map is fully black in those places, but there is still some reflection from the lights. any ideas?

&stc=1&d=1474240198

I figured out my original question, so that has been edited out**

That’s all, thank you so much for your time!

Looks like Substance plugin is limited to 2k max.

Making holes fully black is a bit tricky. You could try setting base color and specular to zero and roughness to 1, but you would still have lighting affect it.
Perhaps, detaching the hole mesh and assigning it a separate UNLIT material is acceptable.

Zero basecolor and specular gives you fully pitch black result. Those pixels still cost as much.

Thanks for the replies. It turns out that to import 4k textures with the substance plugin, you have to set it to GPU processing instead of CPU processing in the settings.

Now the black: In the picture above the Diffuse texture is 100 % black, and the roughness is fully rough. The AO map is fully black as well. Does anyone know any other things to try besides cutting apart the mesh? is there some sort of map that I can use to tell unreal not to light that part of the mesh if I make a mask?

You need to make the specular value black as well.

Awesome! I added a constant to the spec to test it out, but I designed the textures without a spec map. How can I apply the spec to just the black areas in the material, I can’t simply use the AO map because there will be too much spec on the white areas. I guess I need to know if you can mask a specular map? Thanks!

I suppose you could subtract .5 from the AO mask (or multiply it, or clamp it) before plugging it into the specular input. That wouldn’t mask it as such, but it would prevent the specularity from going higher than .5 (the default). That is my first instinct, and probably one of the easiest ways to do what you want.

Thanks for the help. I went into substance designer and did a multiply blend between the AO map and its inverse, that seemed to do the trick.

Just multiply ao map by 0.5 at material and plug that to specular. No need for making another texture.

That’s what I ended up doing in the end. Thanks everyone!