2K Texture imports in at 5Kb and looks awful

This is driving me crazy.

For some reason when I try to import 2k textures (tried png and tga) that were exported from substance designer they come in completely screwed up. However, this only occurs in my current ue project. If I create a new project, they come in correctly.

The file looks fine when I view it outside of ue as well.

Current project (tried importing via drag and drop as well as the input button)

New project

And here is the actual png image.

Edit: I tried overwriting my currents project’s DefaultEngine.ini with a stock one and then changed the startup level but it didn’t fix the issue.

Answered off-site (In the unofficial slack chat) by @Matheww

Here are the steps attempted:
“Change the mip gen settings at the top to NoMipmaps, then reimport button at the top, then save”

“I don’t know why but your project is setting the default mip to the lowest setting even tho the ui does not indicate that”

“yep if you went to your good project and changed the mip to 11 using the normal settings of generate you would find its the same size and looks the same as your bugged project but I couldn’t recreate here ​why​ your project was showing the wrong mip. Normally thats something like low texture memory or a bad settings for your texture mip ranges on your camera or heck even streaming textures could cause it technically.”

“well yeah that’s what mips are for: lower memory cost and intended to be used from farther away ​but​ if your scene needs 2gb of ram and you have 1gb on the card it will swap out lower mips to save space. thats the texture streaming in UE4”

Answer: “gpu only has 512MB”

"you can ​try​ going into project settings, rendering, Texture Streaming and checking it off. restart the editor "

In the end it seems that it’s possible his (Your) graphic card isn’t powerful enough (It’s a 6850 HD).

Hopefully this helps someone else coming across this. Mad props for @Matheww for his support!