25fps in VR, 120 fps on monitor

I’m i the only one that have that pb. When i play in vr, it’s lagging every time i move the vr with my head but on screen, it look smooth.

But if i move the camera ingame with the joystick, look smooth…

Hey Ga.rheault,

To help you out further we are going to need the following information.

System Specs
UE4 Version
Video Card driver version
Oculus driver version

With this information we can see if you might be using some software that does not work with the version of UE4 you are using and go from there if that does not fix your problems.


Sam Deiter

GTX 980ti 32gb of ram
Unreal 4.10
Driver 359.06
Oculus driver 0.8

Nothing, Am i the only one that have a lag with the occulus rift DK2 ?

I experience the same issue

GTX 670

Latest Drivers


Oculus driver 0.8

Hey Ga.rheault,

Your drivers and system look up to the task of handling VR in UE4. Have you tried to see what performance is like when using the Showdown demo? If not please download and run that then let us know how it performs or if you experience any lag. Also what project were you using when you ran into these problems?

Your showdown demo is running at 13ms on the oculus and 8ms full screen. My game is runing at 23ms on the oculus rift but runing a 9ms full screen…why ?

My project isn’t that heavy. Do i need to lower the texture (2k from 1k texture) or i need to do something else ?

A DK2 asks a lot of your GPU compared to a monitor.
Did you try to lower your quality settings?

You should be able to isolate the core of your problem by doing some research and profiling as described in the tutorials.

When I had the same problem with a DK2, the “stat unit” command in the console showed me that my GPU was the weakest link. After profiling as described in the tutorials, I found out that the GPU spend too much time on unnecessary complex lighting. The framerate improved by 50% when I replaced that part.

A fast way to increase the framerate (while loosing quality), try the console command: hmd sp 100 or hmd sp 70

Perceptive hit the proverbial nail on the head with their comment. I would suggest you try what he/she mentioned and let us know if that worked.

Yeap,Just by typing HMD SP 100, the render when from 20 ms ish at 13 and now it’s fix ish (certain area required some cleaning from me).

And i’ll go read a little bit more on Performance and Profiling.