2 errors causing each other

well something is missing somewhere, Even tho you can’t launch the editor you should be able to open the Visual studio solution.
once in there the build should tell you more than what you actually see.

I seem to have a dilemma regarding two errors.
My first error is as follows: CombatStarship.h(15): error : ‘CombatStarship’ can’t be compiled: Parent class ‘Starship’ has errors

The only error in Starship is that it cannot open the generated header. However, because I have the above error, I believe I cannot generate my headers. What do I do?

I cannot recompile the DLL and I cannot get into the editor.

I don’t think I understand. The error I gave was from my build. Here is the full log if you want.

the files have the same name, and ive had never had issues with them. They worked even since project creation

check your Build.cs. and Target.cs to verify the names there. UBT seems to be trying to target a project that does not exist. A variation with some names will cause this kind of errors.

You are right I’m an idiot and did not read the report correctly, I suspect your CombatStarship inherits from Starship. Something you do at line 15 in CombatStarship seems to call something from Starship. it would help to see a bit of these files. Did you modify them before the build?

line 15 is the CombatStarship declaration. I made heavy modifications to my code since the last build. I had exited the editor while in the middle of incorporating a bunch of new changes to my code. However, next time I tried to open the editor, it failed to open. I finished incorporating my change and now my code is ready. That is when the aforementioned problem started. here is the relevant code

This compiles

I have removed a lot of things from header files. Keep them as clean as possible as the more you have in the headers the more links are created and it can take forever to compile.
I have moved a lot of things from public to protected as it should be if you don’t really need to access them from outside.

Hope it helps.

I like the conventional things and such but i still have the same error. the generated.h cant be opened. Looking at my error list its actually a bunch of generated.h files, not just this one. But CombatStarship is the only class that can’t compile due to the parent having errors

I did try your files. I had to make minor adjustments to get it to work with my code (changing the cases of methods and such), and I was able to see all of my other issues in my code (which I was unable to do after my issues started), and now my only errors are the failiure to include generated headers in most (if not all) of my classes.

You might have a buggy pre compiled header that is not being reprocessed. try to clean the solution before recompiling. Did you try my files?

yes the problem here is with the UBT. it does not include the proper files where it should. there are a few fix here and there but mostly the issue is that the generated files are not properly included into the solution.
The path you are looking for is in your ProjectName/Intermediate/Build/Win64/UE4Editor/Inc
Here you need to include all the folders in your solution… and yes there are a bunch of them :s

this thread should provide you with what you need to properly add the files you need UE4.20 is missing the IntelliSense IncludePath for the *.generated.h files

I pulled an older version of my game and then replaced the source with my new source. All my include issues are gone, but my only issue on my log is the combatstarship starship error thing. Screenshots::

Are you including “GameFramework/Actor.h” in you cpp file?
No. In fact it has to be in your Starship.h

It is already in my Starship.h

this is very strange. Can you try to use only my code and see if it compiles? and if it does try to add some of your code and for each addition try to compile and see when it fails

Needs forward declaration?

I found the solution a while back but didnt post my results. I pulled an old version of my project from git and replaced the code. There were several circular dependencies, and even forward declarations wouldn’t let it compile. I just restructured my code and it worked.