1 sided sprites?

Hi @anonymous_user_63e2b454! Welcome to the forums!

I’m not exactly sure what you are trying to accomplish here. Would you mind sharing more detail about what you are trying to do or correct?

Any additional information you can provide will be a great help in solving your problem.

Well, every material is usually 1 sided, unless you turn on the switch for it to be two sided (in the material settings).
So if your question is, how to let the player be visible all the time, while the background is visible only from one side, then you just have to make sure, that your player always faces the front side to the camera, if you are using simple planes as meshes for background and player.

If thats the wrong answer, then i would propose


I’m sorry if my english is bad, or my grammar is wrong.

But I’m working on a simple 2.5d side scroller and there is one level where you can change the camera angle on 4 angles Front, Back, Right and Left.

I want it so that when you change your camera angle to Front, all the sprites that is not facing the camera, not appear.

But this is how all materials work by default.

Look for "Two Sided " In material properties. Should be off.

I’m new to unreal so I don’t really know how things work.

But how do I make that work on paper 2d sprites?

Paper2d uses Texture Mapped Planar Mesh so it’s rendered on both sides.
You can disable that by console command:

r.Paper2D.DrawTwoSided 0

It works in an odd way, so you may need to reapply the material with Two Sided disabled after setting it to 0.

1 Like

How do I fix this?

Hmm. I had no this issue. Probably cause I’ve used the RenderComponent:

Try doing this instead of disabling Two Sided then:

That is modified DefaultSpriteMaterial.
TwoSidedSign node is returning -1 for backside of the polygon and 1 for front face. Saturate clamps it to 0-1.

This way you can also use it to render 2 different textures on back and front (just plug one to lerp).