Download

Zero Gravity Movement?

Me and my friend are making a simple space game but we can’t make the character rotate all around so that no where is up. Unreal won’t let us rotate the character upside-down and move smoothly like he’s using a jetpack. Help Would Be Greatly Appreciated!

Thanks!

Turn off gravity and create your own player controller to achieve this. If you are just trying to use the default player controller then its configured to do specific things, not the kind of things you want. You could apply forces in specific locations on the player to move him around or just fake his movement.

In Unreal, and more specifically the Character class, gravity is hard-coded to be in the negative-Z direction. This results in the assumption(I assume) that the player will always be right side up. You have two options:

  1. Try checking the Use Controller Roll(or similar) boolean in the Character Movement Component on your character. If you then hook up your roll input to an Add Controller Roll node in your character, that might give you the functionality you need.
  2. Or, you could create a custom Character class. Not really advised, there’s a lot of work that went into that class. However, it might be necessary.

In the project settings under Physics you can change the gravity value. You can also manually change it for any mesh

We got the smooth rotation to work using some of the suggestions but there were other problems. The character won’t make a whole 360 rotation and ends up on its side. On top of that the game thinks your still upright so when you look up you end up looking to the side. Me and my friend are trying to setup custom character controllers to help with this.