Download

Zero blend times in Transitions?

Hi people,

When setting up my transitions from, say… an Idle to a ‘monkeybar’ Swing, I’ve added an animation to manually control the transitional movement. I have three animations, essentially: -

MonkeyIdle > Idle_To_Monkey > MonkeySwing (Take a look at the screenshot)

If I set the blend time to 0.0 strange things happen… like it will play the IdleToMonkey or MonkeyToIdle over and over and over again. (I had similar problems with the Epic tutorials involving landing after a jump). I don’t want any blend time. As the last frame of one animation exactly matches the first frame of the next animation. I’ve tried setting this up using a Montage, but I haven’t got enough knowledge with that yet. I’m getting there. But I can’t solve this with it, at the moment. Any blending is messing up the hands being able to grab the rungs correctly.

I’ve tried combinations of ‘time remaining’ and ‘ratio remaining’ of zero… and changing the blend time in the BP transition to zero, too.

Any help would be appreciated.

Thanks,

Neil

[EDIT: It would seem that turning off the animation’s loop flag has helped, but not totally.

4fef25d0ab9415363b293f8542aab1c8ae211869.png