Hello, I’ve found an older question that was answered, but I can’t seem to find the Translucent Sort Order option in my Sprite Detailsl Panel :frowning:

The issue is as described here Z-Buffer problems with paper2D sprites using Translucent material - Rendering - Epic Developer Community Forums

I’d appreciate any help regarding how to change that option.
Thank you

Hi -

Click on the Advanced Rollout of the Sprites Rendering section in the details panel and you will see the Translucency Sort Priority option. YOu can also type Translucency Sort Priority in the Detail Panel’s search bar and it will appear as well.

Thank You

Eric Ketchum

Thank you for your answer.
Because of my lack of knowledge I didn’t use actors for some sprites and I couldn’t set the option. I kinda figured that out after doing other things and getting to understand more about how UE works.

I ran into this problem and rather than manually set sort priorities for every sprite, I made every sprite a blueprint and I added the following code to the construction script:

This is assuming you’re using Z up, X forward and positive Y going towards the player in the real world and -Y going away from the user, towards the back of the monitor.

If you’re using Y forward instead of X, then you’ll need to change which axis you use as your sort basis in the script.

Good luck!