Download

Your Cooking system SUCKs, Epic!

Sorry, but I have to say it so bluntly.

After working on a project for over a year now and going through ups and downs with UE I was a pretty happy camper. Until now.

I am now trying to cook a version for small scale testing and I’m getting bothing but red line errors in the cooking tool WITH ABSOLUTELY NO HINT WHATSOEVER WHAT GOES WRONG!

I mean, the game runs without problems in the editor. So why is it your cooking tool finds things to complain about that are obviously not a problem otherwise? And why isn’t there information WHAT is causing the errors? THIS IS ABSOLUTELY USELESS, EPIC!

I have been spending two days now working on moving my project bit by bit to a virgin project so that I can figure out from one step to the next which one causes the error which doesn’t mean that I will be able to figure out what causes the error once I have the files identified. This is truly the most frustrating experience in my year or so of working with Unreal, not to mention a waste of my time.

I would STRONGLY suggest that you invest some time fixing the cooking process instead of adding useless optical gimmicks which 95% of us can neither use nor even see unless there is a “before” and “after” picture with a red arrow pointing to the difference.

This is serious and from my research these days in the forum and answerhub I can see that others have the same difficulties with the cooking system.

Just for fun I include the error messages here although I dont expect anybody to be able to guess what “Unknown Cook Error” means, but just so that you see, how useless these “error messages” are

UE4Editor-Cmd: [2016.12.10-10.42.46:063] 0]LogInit:Display:
UE4Editor-Cmd: [2016.12.10-10.42.46:073] 0]LogInit:Display: Warning/Error Summary (Unique only)
UE4Editor-Cmd: [2016.12.10-10.42.46:083] 0]LogInit:Display: -----------------------------------
UE4Editor-Cmd: [2016.12.10-10.42.46:093] 0]LogInit:Display: LogLinker:Warning: Can’t find file ‘/Game/Client/ThirdPersonOverview’
UE4Editor-Cmd: [2016.12.10-10.42.46:103] 0]LogInit:Display: LogUObjectGlobals:Warning: Failed to load ‘/Game/Client/ThirdPersonOverview’: Can’t find file ‘/Game/Client/ThirdPersonOverview’
UE4Editor-Cmd: [2016.12.10-10.42.46:113] 0]LogInit:Display: LogUObjectGlobals:Warning: Failed to find object ‘Class /Game/Client/ThirdPersonOverview.ThirdPersonOverview_C’
UE4Editor-Cmd: [2016.12.10-10.42.46:123] 0]LogInit:Display: LogUObjectGlobals:Warning: Failed to find object ‘Object /Game/Client/ThirdPersonOverview.ThirdPersonOverview_C’
UE4Editor-Cmd: [2016.12.10-10.42.46:133] 0]LogInit:Display: LogRedirectors:Warning: String Asset Reference ‘/Game/Client/ThirdPersonOverview.ThirdPersonOverview_C’ was not found! (Referencer ‘None’)
UE4Editor-Cmd: [2016.12.10-10.42.46:143] 0]LogInit:Display:
UE4Editor-Cmd: [2016.12.10-10.42.46:153] 0]LogInit:Display: Success - 0 error(s), 9 warning(s)
UE4Editor-Cmd: [2016.12.10-10.42.46:163] 0]LogInit:Display:
UE4Editor-Cmd:
UE4Editor-Cmd: Execution of commandlet took: 13.82 seconds
UE4Editor-Cmd: [2016.12.10-10.42.48:103] 0]LogOnline:Display: Unloading online subsystem: NULLWindows GetLastError: The operation completed successfully. (0)
UE4Editor-Cmd: begin: stack for UAT
UE4Editor-Cmd: === Critical error: ===
UE4Editor-Cmd:
UE4Editor-Cmd: Fatal error: [File:D:\Build++UE4+Release-4.14+Compile\Sync\Engine\Source\Runtime\Launch\Private\Windows\LaunchWindows.cpp] [Line: 83]
UE4Editor-Cmd: SECURE CRT: Invalid parameter detected.
UE4Editor-Cmd: Expression: Unknown Function: Unknown. File: Unknown Line: 0
UE4Editor-Cmd:
UE4Editor-Cmd:
UE4Editor-Cmd:
UE4Editor-Cmd:
UE4Editor-Cmd: end: stack for UAT
UE4Editor-Cmd: FPlatformMisc::RequestExit(1)
CommandUtils.Run: Run: Took 24.169s to run UE4Editor-Cmd.exe, ExitCode=3
Project.Cook: Cook failed. Deleting cooked data.
Program.Main: ERROR: AutomationTool terminated with exception: AutomationTool.AutomationException: Cook failed. —> AutomationTool.AutomationException: BUILD FAILED: Failed while running Cook for C: mp\UnrealProjects\Client\Client.uproject; see log C:\Users\Patric\AppData\Roaming\Unreal Engine\AutomationTool\Logs\C+Program+Files+(x86)+Epic+Games+4.14\Cook-2016.12.10-02.42.48.txt
at AutomationTool.CommandUtils.RunCommandlet(FileReference ProjectName, String UE4Exe, String Commandlet, String Parameters)
at AutomationTool.CommandUtils.CookCommandlet(FileReference ProjectName, String UE4Exe, String] Maps, String] Dirs, String InternationalizationPreset, String] CulturesToCook, String TargetPlatform, String Parameters)
at Project.Cook(ProjectParams Params)
— End of inner exception stack trace —
at Project.Cook(ProjectParams Params)
at BuildCookRun.DoBuildCookRun(ProjectParams Params)
at BuildCookRun.ExecuteBuild()
at AutomationTool.BuildCommand.Execute()
at AutomationTool.Automation.Execute(List1 CommandsToExecute, CaselessDictionary1 Commands)
at AutomationTool.Automation.Process(String] Arguments)
at AutomationTool.Program.MainProc(Object Param)
at AutomationTool.InternalUtils.RunSingleInstance(Func`2 Main, Object Param)
at AutomationTool.Program.Main()
Program.Main: AutomationTool exiting with ExitCode=25 (Error_UnknownCookFailure)
BUILD FAILED

1 - have you ran a research for ‘error’ in the log?
2 - usually you don’t wait a year to produce a packaged version of the project to avoid such situations, the good idea would be to build at least once a week
3 - if you want your project to cook, we’ll need full access to your log report
4 - it does not suxx, it is just talking in a foreign language and we have to learn it
5 - make backups of the project every once in a while
6 - check the logs in your project folder

Always test if your game compiles before backing it up. I had to learn this lesson the hard way too. I had to salvage what I could by migrating and started anew.

Always make weekly or monthly builds and backups…

see log C:\Users\Patric\AppData\Roaming\Unreal Engine\AutomationTool\Logs\C+Program+Files+(x86)+Epic+Games+4.14\Cook-2016.12.10-02.42.48.txt

Yes these are all great suggestions. I understand that I should have started cooking the very first week to figure out early when it stops cooking, but frankly, when you start learning UE and struggle to make your first program, you have other things in mind than cooking it. You assume that cooking works or at least will tell you something like “error of type X in this location” instead of “Unknown Cooking Failure”. I tried to learn that language by the way but that vocabulary was not in the book.

And yes I checked that logfile but it doesnt contain any hint either

The fact is and remains the same, which is that the cooking system needs to give better output in case of a failure!

Better than if the Sucking system cooks :smiley:

Sorry. Have my silly five minutes and couldnt resist :stuck_out_tongue:

I suggest looking at these:



UE4Editor-Cmd: [2016.12.10-10.42.46:093] 0]LogInitisplay: LogLinker:Warning: Can't find file '/Game/Client/ThirdPersonOverview'
UE4Editor-Cmd: [2016.12.10-10.42.46:103] 0]LogInitisplay: LogUObjectGlobals:Warning: Failed to load '/Game/Client/ThirdPersonOverview': Can't find file '/Game/Client/ThirdPersonOverview'
UE4Editor-Cmd: [2016.12.10-10.42.46:113] 0]LogInitisplay: LogUObjectGlobals:Warning: Failed to find object 'Class /Game/Client/ThirdPersonOverview.ThirdPersonOverview_C'
UE4Editor-Cmd: [2016.12.10-10.42.46:123] 0]LogInitisplay: LogUObjectGlobals:Warning: Failed to find object 'Object /Game/Client/ThirdPersonOverview.ThirdPersonOverview_C'
UE4Editor-Cmd: [2016.12.10-10.42.46:133] 0]LogInitisplay: LogRedirectors:Warning: String Asset Reference '/Game/Client/ThirdPersonOverview.ThirdPersonOverview_C' was not found! (Referencer 'None')


Yes, I know that but about 500 people have reported the same problems with “missing ThirdPersonOverview” and Epic always answers the same thing: This is only a warning you can ignore it. So this can not be the reason.

The Cooking System is pretty okay, but it could have some more meaningful errors. It basically says “The cook failed, because there was an error when cooking”. The StackTrace won’t help because it throws an exception within the engine, not in the project itself.

That was actually a very very good one! xD

Anyways, i must admit that i really don’t like that when i start cooking i have to copy the entire log and search for the errors in sublime.

8f07cc5874065137f3d652a68713d37e700da421.png

In the Output Log window you can find your errors and warnings quickly by switching these on an off. There likely won’t be any real context with some of them because you need what’s written before or after them in some case, but it can be a quick way to assess the issue you have.


@Wallenstein

The full log here is most helpful. Portions of it do not help see the overall issue. Sometimes there are plugins that are known to cause conflicts with packaging like the MODO Material plugin, for instance, will cause package failures and needs to be disabled before you package. There are others as well that do this. This is all printed in the top of the log which plugins are enabled and can help us identify why you may be having packaging issues. Alternatively, you can disable any plugins you’ve downloaded from the marketplace and try to package to see if that resolves the issue as well.

If you’ve got a lot of warnings in your project try fixing these. Often it’s just a matter of fixing up redirectors from content that was removed or moved inside the project.

Wow that will save a lots of time, thank you very much Tim! :slight_smile:

But it would be actually very usefull to have all the errors printed out after the build fails.

To get a cook failure when it says 0 errors is weird but what I always do after a cook failure is select all, copy, paste to note and then control f error. It takes less than 2 minutes to find the errors in the list. One that seems to effect me a lot is the filename is too long which is a pain in the ***. Even though it says 0 errors I wouldn’t trust that and look for the errors anyway. If you post them here someone will know whats going on.

There is no meaningful error message in any of the log files. and yes I know how to search for “error” in a text, but all it says is that an error occurred together with an error number and otherwise nothing.
Why are we arguing about this? There IS NO HELP FROM THE COOKING TOOL! When it fails, it does not tell you WHY it fails and it SHOULD tell you so. Why is that so hard to accept?

And yes I fixed all redirectors and objects except the “thirdPersonOverview” which is nothing serious according to Epics answers elesewhere so I really see no reason why the cooking process should crash when the game runs in the editor

Ok, and just to show that there really is nothing, i post the full logfile here as Tim Hobson has requested:

Log file open, 12/12/16 16:16:20
LogInit: Build: ++UE4+Release-4.14-CL-3224400
LogInit: Engine Version: 4.14.1-3224400+++UE4+Release-4.14
LogInit: Compatible Engine Version: 4.14.0-3195953+++UE4+Release-4.14
LogInit: Net CL: 3195953
LogDevObjectVersion: Number of dev versions registered: 13
LogDevObjectVersion: Dev-Blueprints (B0D832E4-1F89-4F0D-ACCF-7EB736FD4AA2): 7
LogDevObjectVersion: Dev-Build (E1C64328-A22C-4D53-A36C-8E866417BD8C): 0
LogDevObjectVersion: Dev-Core (375EC13C-06E4-48FB-B500-84F0262A717E): 1
LogDevObjectVersion: Dev-Editor (E4B068ED-F494-42E9-A231-DA0B2E46BB41): 8
LogDevObjectVersion: Dev-Framework (CFFC743F-43B0-4480-9391-14DF171D2073): 17
LogDevObjectVersion: Dev-Mobile (B02B49B5-BB20-44E9-A304-32B752E40360): 0
LogDevObjectVersion: Dev-Networking (A4E4105C-59A1-49B5-A7C5-40C4547EDFEE): 0
LogDevObjectVersion: Dev-Online (39C831C9-5AE6-47DC-9A44-9C173E1C8E7C): 0
LogDevObjectVersion: Dev-Physics (78F01B33-EBEA-4F98-B9B4-84EACCB95AA2): 0
LogDevObjectVersion: Dev-Platform (6631380F-2D4D-43E0-8009-CF276956A95A): 0
LogDevObjectVersion: Dev-Rendering (12F88B9F-8875-4AFC-A67C-D90C383ABD29): 12
LogDevObjectVersion: Dev-Sequencer (7B5AE74C-D270-4C10-A958-57980B212A5A): 1
LogDevObjectVersion: Dev-VR (D7296918-1DD6-4BDD-9DE2-64A83CC13884): 0
LogInit: Compiled (64-bit): Dec 7 2016 02:14:32
LogInit: Compiled with Visual C++: 19.00.23026.00
LogInit: Build Configuration: DebugGame
LogInit: Branch Name: ++UE4+Release-4.14
LogInit: Command line: C:\Data\Mikaboshi2\UnrealProjects\Client\Client.uproject -run=Cook -Map=ThirdPersonExampleMap+StartScreenMap -TargetPlatform=WindowsNoEditor -fileopenlog -unversioned -debug -createreleaseversion=1 -abslog=“C:\Program Files (x86)\Epic Games\4.14\Engine\Programs\AutomationTool\Saved\Cook-2016.12.12-16.16.19.txt” -stdout -FORCELOGFLUSH -CrashForUAT -unattended -UTF8Output
LogInit: Base directory: C:/Program Files (x86)/Epic Games/4.14/Engine/Binaries/Win64/
LogInit: Installed Engine Build: 1
LogInit: Presizing for max 8388607 objects, including 0 objects not considered by GC, pre-allocating 0 bytes for permanent pool.
LogInit: Object subsystem initialized
[2016.12.13-00.16.20:810] 0]LogInit: Selected Device Profile: [Windows]
[2016.12.13-00.16.20:838] 0]LogInit: Applying CVar settings loaded from the selected device profile: [Windows]
[2016.12.13-00.16.20:856] 0]LogInit: Computer: RED
[2016.12.13-00.16.20:858] 0]LogInit: User: Patric
[2016.12.13-00.16.20:868] 0]LogInit: CPU Page size=65536, Cores=4
[2016.12.13-00.16.20:878] 0]LogInit: High frequency timer resolution =3.914150 MHz
[2016.12.13-00.16.20:888] 0]LogMemory: Memory total: Physical=31.9GB (32GB approx)
[2016.12.13-00.16.20:898] 0]LogMemory: Platform Memory Stats for Windows
[2016.12.13-00.16.20:908] 0]LogMemory: Process Physical Memory: 259.98 MB used, 259.98 MB peak
[2016.12.13-00.16.20:919] 0]LogMemory: Process Virtual Memory: 262.64 MB used, 262.64 MB peak
[2016.12.13-00.16.20:928] 0]LogMemory: Physical Memory: 8550.29 MB used, 24153.96 MB free, 32704.25 MB total
[2016.12.13-00.16.20:938] 0]LogMemory: Virtual Memory: 636.21 MB used, 24153.96 MB free, 8388608.00 MB total
[2016.12.13-00.16.21:005] 0]LogTextLocalizationManager: No specific translations for (‘en-US’) exist, so (‘en’) translations will be used.
[2016.12.13-00.16.21:591] 0]LogShaderCompilers: Guid format shader working directory is -8 characters bigger than the processId version (…/…/…/…/…/…/Data/Mikaboshi2/UnrealProjects/Client/Intermediate/Shaders/WorkingDirectory/3476/).
[2016.12.13-00.16.21:601] 0]LogShaderCompilers: Cleaned the shader compiler working directory ‘C:/Users/Patric/AppData/Local/Temp/UnrealShaderWorkingDir/195B56304530B256A384EF87B69C5137/’.
[2016.12.13-00.16.21:611] 0]LogShaderCompilers:Display: Using Local Shader Compiler.
[2016.12.13-00.16.22:053] 0]LogDerivedDataCache:Display: Max Cache Size: 512 MB
[2016.12.13-00.16.22:093] 0]LogDerivedDataCache: Loaded boot cache 0.04s 51MB C:/Users/Patric/AppData/Local/UnrealEngine/4.14/DerivedDataCache/Boot.ddc.
[2016.12.13-00.16.22:095] 0]LogDerivedDataCache:Display: Loaded Boot cache: C:/Users/Patric/AppData/Local/UnrealEngine/4.14/DerivedDataCache/Boot.ddc
[2016.12.13-00.16.22:105] 0]LogDerivedDataCache: FDerivedDataBackendGraph: Pak pak cache file …/…/…/…/…/…/Data/Mikaboshi2/UnrealProjects/Client/DerivedDataCache/DDC.ddp not found, will not use a pak cache.
[2016.12.13-00.16.22:115] 0]LogDerivedDataCache: Unable to find inner node Pak for hierarchical cache Hierarchy.
[2016.12.13-00.16.22:125] 0]LogDerivedDataCache: FDerivedDataBackendGraph: CompressedPak pak cache file …/…/…/…/…/…/Data/Mikaboshi2/UnrealProjects/Client/DerivedDataCache/Compressed.ddp not found, will not use a pak cache.
[2016.12.13-00.16.22:135] 0]LogDerivedDataCache: Unable to find inner node CompressedPak for hierarchical cache Hierarchy.
[2016.12.13-00.16.22:164] 0]LogDerivedDataCache:Display: Pak cache opened for reading …/…/…/Engine/DerivedDataCache/Compressed.ddp.
[2016.12.13-00.16.22:175] 0]LogDerivedDataCache: Using Local data cache path C:/Users/Patric/AppData/Local/UnrealEngine/Common/DerivedDataCache: Writable
[2016.12.13-00.16.22:705] 0]LogTemp:Display: Loaded TP AllDesktopTargetPlatform
[2016.12.13-00.16.22:791] 0]LogTemp:Display: Loaded TP MacClientTargetPlatform
[2016.12.13-00.16.22:870] 0]LogTemp:Display: Loaded TP MacNoEditorTargetPlatform
[2016.12.13-00.16.23:004] 0]LogTemp:Display: Loaded TP MacServerTargetPlatform
[2016.12.13-00.16.23:157] 0]LogTemp:Display: Loaded TP MacTargetPlatform
[2016.12.13-00.16.23:332] 0]LogTemp:Display: Loaded TP WindowsClientTargetPlatform
[2016.12.13-00.16.23:434] 0]LogTemp:Display: Loaded TP WindowsNoEditorTargetPlatform
[2016.12.13-00.16.23:506] 0]LogTemp:Display: Loaded TP WindowsServerTargetPlatform
[2016.12.13-00.16.23:577] 0]LogTemp:Display: Loaded TP WindowsTargetPlatform
[2016.12.13-00.16.23:661] 0]LogTemp:Display: Loaded TP AndroidTargetPlatform
[2016.12.13-00.16.23:733] 0]LogTemp:Display: Loaded TP Android_ASTCTargetPlatform
[2016.12.13-00.16.23:814] 0]LogTemp:Display: Loaded TP Android_ATCTargetPlatform
[2016.12.13-00.16.23:899] 0]LogTemp:Display: Loaded TP Android_DXTTargetPlatform
[2016.12.13-00.16.23:990] 0]LogTemp:Display: Loaded TP Android_ETC1TargetPlatform
[2016.12.13-00.16.24:053] 0]LogTemp:Display: Loaded TP Android_ETC2TargetPlatform
[2016.12.13-00.16.24:163] 0]LogTemp:Display: Loaded TP Android_MultiTargetPlatform
[2016.12.13-00.16.24:165] 0]LogTemp:Display: Loaded TP Android_PVRTCTargetPlatform
[2016.12.13-00.16.24:209] 0]LogTemp:Display: Loaded TP HTML5TargetPlatform
[2016.12.13-00.16.24:294] 0]LogTemp:Display: Loaded TP IOSTargetPlatform
[2016.12.13-00.16.24:331] 0]LogTemp:Display: Loaded TP TVOSTargetPlatform
[2016.12.13-00.16.24:388] 0]LogTemp:Display: Loaded TP LinuxClientTargetPlatform
[2016.12.13-00.16.24:445] 0]LogTemp:Display: Loaded TP LinuxNoEditorTargetPlatform
[2016.12.13-00.16.24:505] 0]LogTemp:Display: Loaded TP LinuxServerTargetPlatform
[2016.12.13-00.16.24:567] 0]LogTemp:Display: Loaded TP LinuxTargetPlatform
[2016.12.13-00.16.24:575] 0]LogTargetPlatformManager:Display: Building Assets For WindowsNoEditor
[2016.12.13-00.16.24:952] 0]LogInit: Selected Device Profile: [Windows]
[2016.12.13-00.16.28:535] 0]LogMeshUtilities: Using QuadricMeshReduction for automatic static mesh reduction
[2016.12.13-00.16.28:654] 0]LogSimplygon: Simplygon DLL not present - disabling.
[2016.12.13-00.16.28:833] 0]LogMeshUtilities: Using SimplygonSwarm for distributed automatic mesh merging
[2016.12.13-00.16.28:872] 0]LogMeshUtilities: No automatic skeletal mesh reduction module available
[2016.12.13-00.16.28:901] 0]LogMeshUtilities: No automatic mesh merging module available
[2016.12.13-00.16.30:041] 0]LogNetVersion: GetLocalNetworkVersion: CL: 3195953, ProjectName: client, ProjectVersion: , EngineNetworkVersion: 2, GameNetworkVersion: 0, NetworkChecksum: 1372479491
[2016.12.13-00.16.30:194] 0]LogAssetRegistry: FAssetRegistry took 0.0001 seconds to start up
[2016.12.13-00.16.30:276] 0]LogPackageLocalizationCache: Processed 3 localized package path(s) for 2 prioritized culture(s) in 0.016945 seconds
[2016.12.13-00.16.30:558] 0]LogInit: WinSock: version 1.1 (2.2), MaxSocks=32767, MaxUdp=65467
[2016.12.13-00.16.33:809] 0]LogLinker:Warning: Can’t find file ‘/Game/Client/ThirdPersonOverview’
[2016.12.13-00.16.33:875] 0]LogUObjectGlobals:Warning: Failed to load ‘/Game/Client/ThirdPersonOverview’: Can’t find file ‘/Game/Client/ThirdPersonOverview’
[2016.12.13-00.16.33:940] 0]LogLinker:Warning: Can’t find file ‘/Game/Client/ThirdPersonOverview’
[2016.12.13-00.16.33:957] 0]LogUObjectGlobals:Warning: Failed to load ‘/Game/Client/ThirdPersonOverview’: Can’t find file ‘/Game/Client/ThirdPersonOverview’
[2016.12.13-00.16.33:989] 0]LogUObjectGlobals:Warning: Failed to find object ‘Class /Game/Client/ThirdPersonOverview.ThirdPersonOverview_C’
[2016.12.13-00.16.56:611] 0]LogWindows:Error: begin: stack for UAT
[2016.12.13-00.16.56:691] 0]LogWindows:Error: === Critical error: ===
[2016.12.13-00.16.56:953] 0]LogWindows:Error:
[2016.12.13-00.16.57:150] 0]LogWindows:Error: Fatal error!
[2016.12.13-00.16.57:271] 0]LogWindows:Error:
[2016.12.13-00.16.57:853] 0]LogWindows:Error: Unhandled Exception: EXCEPTION_ACCESS_VIOLATION reading address 0xffff00e0
[2016.12.13-00.16.58:712] 0]LogWindows:Error:
[2016.12.13-00.16.58:722] 0]LogWindows:Error: UE4Editor-Core.dll!rml::internal::ExtMemoryPool::initTLS()
[2016.12.13-00.16.58:732] 0]LogWindows:Error: UE4Editor-Core.dll!scalable_malloc()
[2016.12.13-00.16.58:742] 0]LogWindows:Error: UE4Editor-Core.dll!FMallocTBB::Malloc() [d:\build++ue4+release-4.14+compile\sync\engine\source\runtime\core\private\hal\malloctbb.cpp:44]
[2016.12.13-00.16.58:752] 0]LogWindows:Error: UE4Editor-Core.dll!FTextFormatter::Format() [d:\build++ue4+release-4.14+compile\sync\engine\source\runtime\core\private\internationalization extformatter.cpp:880]
[2016.12.13-00.16.58:762] 0]LogWindows:Error: UE4Editor-Core.dll!FText::Format() [d:\build++ue4+release-4.14+compile\sync\engine\source\runtime\core\private\internationalization ext.cpp:376]
[2016.12.13-00.16.58:772] 0]LogWindows:Error: UE4Editor-CoreUObject.dll!LoadPackageInternalInner() [d:\build++ue4+release-4.14+compile\sync\engine\source\runtime\coreuobject\private\uobject\uobjectglobals.cpp:1164]
[2016.12.13-00.16.58:805] 0]LogWindows:Error: UE4Editor-CoreUObject.dll!LoadPackage() [d:\build++ue4+release-4.14+compile\sync\engine\source\runtime\coreuobject\private\uobject\uobjectglobals.cpp:1437]
[2016.12.13-00.16.58:815] 0]LogWindows:Error: UE4Editor-CoreUObject.dll!ResolveName() [d:\build++ue4+release-4.14+compile\sync\engine\source\runtime\coreuobject\private\uobject\uobjectglobals.cpp:722]
[2016.12.13-00.16.59:383] 0]LogWindows:Error: UE4Editor-CoreUObject.dll!StaticLoadObjectInternal() [d:\build++ue4+release-4.14+compile\sync\engine\source\runtime\coreuobject\private\uobject\uobjectglobals.cpp:809]
[2016.12.13-00.16.59:740] 0]LogWindows:Error: UE4Editor-CoreUObject.dll!StaticLoadObject() [d:\build++ue4+release-4.14+compile\sync\engine\source\runtime\coreuobject\private\uobject\uobjectglobals.cpp:869]
[2016.12.13-00.16.59:781] 0]LogWindows:Error: UE4Editor-CoreUObject.dll!StaticLoadClass() [d:\build++ue4+release-4.14+compile\sync\engine\source\runtime\coreuobject\private\uobject\uobjectglobals.cpp:893]
[2016.12.13-00.16.59:838] 0]LogWindows:Error: UE4Editor-Client-Win64-DebugGame.dll
[2016.12.13-00.16.59:848] 0]LogWindows:Error: UE4Editor-Client-Win64-DebugGame.dll
[2016.12.13-00.16.59:858] 0]LogWindows:Error: UE4Editor-Client-Win64-DebugGame.dll
[2016.12.13-00.16.59:868] 0]LogWindows:Error: UE4Editor-Client-Win64-DebugGame.dll
[2016.12.13-00.16.59:878] 0]LogWindows:Error: UE4Editor-CoreUObject.dll!UClass::CreateDefaultObject() [d:\build++ue4+release-4.14+compile\sync\engine\source\runtime\coreuobject\private\uobject\class.cpp:2664]
[2016.12.13-00.16.59:888] 0]LogWindows:Error: UE4Editor-CoreUObject.dll!UObjectLoadAllCompiledInDefaultProperties() [d:\build++ue4+release-4.14+compile\sync\engine\source\runtime\coreuobject\private\uobject\uobjectbase.cpp:745]
[2016.12.13-00.16.59:898] 0]LogWindows:Error: UE4Editor-CoreUObject.dll!ProcessNewlyLoadedUObjects() [d:\build++ue4+release-4.14+compile\sync\engine\source\runtime\coreuobject\private\uobject\uobjectbase.cpp:821]
[2016.12.13-00.16.59:908] 0]LogWindows:Error: UE4Editor-CoreUObject.dll!TBaseStaticDelegateInstance<void __cdecl(void)>::ExecuteIfSafe() [d:\build++ue4+release-4.14+compile\sync\engine\source\runtime\core\public\delegates\delegateinstancesimpl.h:1018]
[2016.12.13-00.16.59:918] 0]LogWindows:Error: UE4Editor-Core.dll!TBaseMulticastDelegate<void>::Broadcast() [d:\build++ue4+release-4.14+compile\sync\engine\source\runtime\core\public\delegates\delegatesignatureimpl.inl:922]
[2016.12.13-00.16.59:928] 0]LogWindows:Error: UE4Editor-Core.dll!FModuleManager::LoadModuleWithFailureReason() [d:\build++ue4+release-4.14+compile\sync\engine\source\runtime\core\private\modules\modulemanager.cpp:466]
[2016.12.13-00.16.59:938] 0]LogWindows:Error: UE4Editor-Projects.dll!FModuleDescriptor::LoadModulesForPhase() [d:\build++ue4+release-4.14+compile\sync\engine\source\runtime\projects\private\moduledescriptor.cpp:409]
[2016.12.13-00.16.59:948] 0]LogWindows:Error: UE4Editor-Projects.dll!FProjectManager::LoadModulesForProject() [d:\build++ue4+release-4.14+compile\sync\engine\source\runtime\projects\private\projectmanager.cpp:53]
[2016.12.13-00.16.59:958] 0]LogWindows:Error: UE4Editor-Cmd.exe!FEngineLoop::LoadStartupModules() [d:\build++ue4+release-4.14+compile\sync\engine\source\runtime\launch\private\launchengineloop.cpp:2236]
[2016.12.13-00.16.59:968] 0]LogWindows:Error: UE4Editor-Cmd.exe!FEngineLoop::PreInit() [d:\build++ue4+release-4.14+compile\sync\engine\source\runtime\launch\private\launchengineloop.cpp:1668]
[2016.12.13-00.16.59:978] 0]LogWindows:Error: UE4Editor-Cmd.exe!GuardedMain() [d:\build++ue4+release-4.14+compile\sync\engine\source\runtime\launch\private\launch.cpp:113]
[2016.12.13-00.16.59:988] 0]LogWindows:Error: UE4Editor-Cmd.exe!GuardedMainWrapper() [d:\build++ue4+release-4.14+compile\sync\engine\source\runtime\launch\private\windows\launchwindows.cpp:126]
[2016.12.13-00.16.59:998] 0]LogWindows:Error: UE4Editor-Cmd.exe!WinMain() [d:\build++ue4+release-4.14+compile\sync\engine\source\runtime\launch\private\windows\launchwindows.cpp:202]
[2016.12.13-00.17.00:008] 0]LogWindows:Error: UE4Editor-Cmd.exe!__scrt_common_main_seh() [f:\dd\vctools\crt\vcstartup\src\startup\exe_common.inl:264]
[2016.12.13-00.17.00:018] 0]LogWindows:Error: kernel32.dll
[2016.12.13-00.17.00:028] 0]LogWindows:Error: ntdll.dll
[2016.12.13-00.17.00:038] 0]LogWindows:Error: ntdll.dll
[2016.12.13-00.17.00:048] 0]LogWindows:Error:
[2016.12.13-00.17.00:058] 0]LogWindows:Error: end: stack for UAT
[2016.12.13-00.17.00:078] 0]LogExit: Executing StaticShutdownAfterError
[2016.12.13-00.17.00:089] 0]LogWindows: FPlatformMisc::RequestExit(1)
[2016.12.13-00.17.00:098] 0]Log file closed, 12/12/16 16:17:00

First of all the logs you posted contain many “hints” about what might be the problem.
I think you should check what is referencing the “ThirdPersonOverview.ThirdPersonOverview_C’” asset and fix it, it looks like its causing UAT to crash.

Epic has repeatedly stated that this warning can be ignored.

FYI: I had to rebuild the whole project by hand, copy stuff to a virgin project bit by bit. Now it works. the only difference is, that I rewrote an external DLL as a static link library. that alone wouldn’t do it, but it was one reason. I still had to make a new project and copy my C++ files manually and then migrate the assets piece by piece.

This makes no sense, but at least it works. Given the fact that nothing earthshattering has changed from the old to the new project, I still maintain that the cooking system needs improvement, mainly better error messages.

Also, warnings like these:
UE4Editor-Cmd: [2016.12.16-08.47.00:649] 0]LogUObjectGlobals:Warning: Failed to load ‘/Game/Knight_2_rigged_2’: Can’t find file ‘/Game/Knight_2_rigged_2’
need to include WHERE this asset is referenced.

9 out of 10 times I see this happen is because someone involved did include headers / modules from the UEditor inside game code.
I’ve seen plugin authors doing it as well, got to be careful and double-check extensions you add to the project.
Whatever editor stuff you add into game code will break packaging.