*You do not have sufficient permission to save the following content to disk* 4.22


We are recently experimenting with the new 4.22 engine and exporters. I’m testing both the Revit and 3ds Max exporters (using the same scene from Revit for both). We encounter an error message stating we don’t have permissions to save out content on import and also when trying to save. Ultimately the content will not save, and if we close and re-open the project these assets will be gone.

It’s happening with a variety of different assets in different scenes, and we have seen furniture like desks display this issue along with walls and other objects.

This exact same scene imported into UE4.21 will experience NO issues (even when using the 4.22 exporters for Max and Revit). Until we can resolve this our team must continue building projects in 4.21.

Hi there ,

This is a known Issue which was fixed for 4.22.
So…I’m surprised to see you are still seeing it.

There’s 2 things you could try :

  1. Maybe you would like to update your windows to support long path
    How to enable paths longer than 260 characters in Windows 10

  2. Rename your asset with a shorter name.

Let me know if that doesn’t fix the problem :slight_smile:


Hi Marie-Claude! I tried this again today after reading your post and learned 2 things:

1.) My scene contains many items with even longer names which work fine (I still wish I could rename them in Revit) so this doesn’t seem to be the issue.
2.) All of those items I posted in the screenshot above contain spaces in the filename (between Cornice and _16). I renamed these in UE4, got some errors that they still couldn’t save, removed Redirectors and then it worked.

I will have to find other scenes to test this on, but could you let me know if you think spaces are a likely issue here?

This is strange.

If I do a very basic test in Max with spaces in the name, a sanitization process happens.

In max:

In Unreal:

Can you share the 3ds max scene with us? A wetransfert link sent to pierrefelix.breton@epicgames.com would be fine.

Also, is this straight import then trying to save or you are moving things around in the content browser? Not that its something you should avoid doing - simply that we need to reproduce the problem and fix it.

Thank you Pierre-Felix, I have sent you an email with the file and some further information.

I’m hoping this can be fixed but in the meantime I found I can work in 4.22 but use the 4.21 revit exporter.

Good to know, I’ll try that, thanks.

I’ve had the same issue so here’s the answer I had from the support :

1 - enable long path support in windows using this tutorial >> https://eocloud.cloudferro.com/knowledgebase.php?action=displayarticle&id=135

2 - enable long path support in Unreal Engine in the “Editor preferences” menu.

3 - restart your computer, reopen the project and… voilà ! :slight_smile:

although in this case, the culprit was a unsupported character that quasi invisible to find. a “us” (unit separator, similar to lf or cr) character slipped in the object name from revit.

that bug is being fixed right now.

I’m working with OS X (MAC) and I’m using UE 4.25.
I have the same issue:You do not have sufficient permission to save the following content to disk
What can I do in this case? -It’s supposed this issue was resolved already in UE 4.22

For me, this was a security firewall issue. I had to manually allow Unreal Engine folders to execute, because Windows AntiVirus security measures were blocking them.