Yet another "License not accepted. SDK License..." problem.

I have a build environment I hadn’t touched in a while, but it was all properly configured to build projects and push them to an Android device(Gear VR, particularly). When I came back recently, I updated the engine (I’m now on 4.21.2, and I had been on a 4.17), and now if I try to package an Android project, I immediately get this message:


License not accepted. SDK License must be accepted in the Android project settings to deploy your app to the device.

" (not that this is not the complaint about the build tools licensing).

I searched before posting this and I tried all of the recommended things:

  • Y’know, just go click that button in the Project Settings-- it opens the license, I can click accept, but the original button doesn’t gray out (as though the license had been accepted), and packaging is still unhappy.
  • Used the SDK manager to update the components, forcing a re-acceptance of the licenses through there.
  • Updating the (I think) Documentation Manager (it was some specific component someone recommended-- Android SDK wanted to update it anyway), which also required a new license acceptance.
  • Run the SDK Manager from the command-line to force it to offer me the licenses individually.
  • Fixed the symlink I had pointing to my Java JDK (not 100% sure whether that would matter or not).
  • Verified the contents of the existing license file in …-sdk-windows\licenses contains three lines, the first two of which matched the advice from an old post.
  • Renamed the license file, to treat it as deleted.

Anyone else have a recommendation? There is zero question that I have spent more time getting building to Gear VR to work (and stay working) than I have actually working on a project.