Download

Y-axis problem

Hi, i have this problem with importing objects from 3ds max. In max i’m working with centimeters, when i import object to ue4 and set location to the same value, x and z are good, but y axis is a little off. Does anybody know why ?

Hi Trojanator,

Can you post any images or repro steps for creating this problem?

My test to see if anything was off.

I changed my grid to be 10cm spacing
I made a box that was 40cm all around
I centered this to the world origin
I exported to Unreal Engine 4
I placed mesh in the world and in Top view was able to see that it matched perfectly with the 10cm grid spacing that is setup by default.

Post your steps, asset, or images for better clarification and I’ll look into this.

What engine version are you using?

Tim

Thank for reply, i’m using 4.2.1

I did your test with a box, same result as you.

I try to explain it better. So, i have whole scene in max, and i want to import it to ue4 without manually placing objects. I’m doing it like this - i pick an object, i copy in txt file its xyz location, than i set its location to 0,0,0 and export, in ue4 i import it, place actor in scene and paste location from txt file. So it should be exactly like in max. X and Z are ok, but Y axis is weird, here are some screenshots.

603ab4b9be2ca77a5fe2a3ccaf4a43720dfd6e66.jpeg

and here is how it looks like in ue4 (notice Yaxis)
06ffdf0b8e4176ba4f15be6c961d1a8fa8baad0c.jpeg

Thanks

I’m not entirely sure this is an issue with UE4 at the moment since we’ve both been able to export a cube that has has been centered to the world origin and exported and imported into UE4 with no issue.

Would you be willing to post this asset or create a similar one that has the same issue for me to look at and see where the problem is happening?

Tim

Here is .max file with the floors. Dropbox - Error

Thanks

For stuff like this, what I personally tend to do is reset the pivot of each ‘part’ of my level static meshes to the origin. When they’re imported, I just reset all the transforms to 0 and everything lines up fine. Obviously, this isn’t appropriate for repeating structures where you want to be able to move things around, but for large blocked parts, it works.

Hi,

Sorry I should have mentioned I’m on Max 2013. I can’t open it since it is from a newer version (2014/2014) Can you save it as Max 2013?

Tim

Hope it’ll work

Thank you for getting back so quickly! Once I was able to open it up I was able to see that the Y coordinates did not line up for your two meshes. This is why it was importing and offset a little bit.

To illustrate the problem better I’ve made an animated gif showing the two y-axis pivots and that they are slightly off. I highlight the y coordinate in the bottom right.

If you adjust either one to be the same as the other this will resolve that issue. I adjusted the inner podlaha_2 to match the podlaha_1’s y-axis.

f8c0efd2ad22cb7dac5b9b1fe145baaa3ab4e460.gif

Take a look and see if this helps you out! Let me know how it goes!

Tim

Well, it works now, but do i have to have Ypivot the same value on every object in the scene ?

The Y-axis of the pivot was not the same for both of the meshes. Adjusting this put them even with no offset.