Download

Xcode's metal shader compiler was not found, verify Xcode

Hey folks,
can someone help with this issue?:

Problem:
error in terminal, skipped
UATHelper: Packaging (iOS): LogShaderCompilers: Error: /tmp/3135_2233400218.metal(0): Xcode’s metal shader compiler was not found, verify Xcode has been installed on this Mac and that it has been selected in Xcode > Preferences > Locations > Command-line Tools.
UATHelper: Packaging (iOS): LogMac: Error: appError called: Assertion failed: [File:/Users/build/Build/++UE4/Sync/Engine/Source/Runtime/Engine/Private/ShaderCompiler/ShaderCompiler.cpp] [Line: 4523]
UATHelper: Packaging (iOS):

Can´t solve it…

Xcode is updated
Metal shader compiler - Check
Also installed Homebrew
Command Line Tools updated and in
Xcode-Preferences-Locations-Command Line Tools checked, v. Xcode 11.3 (11C29)
Unreal Engine 4 v. 4.22.3

Thank you in advance!

Is this solved?
I am facing this now.

Please, somebody help us…

XCode ver. 1 1.3.1 (11C504) + CommandLineTools
UE4 ver. 4.22.3


I just upgrade UE4 engine version to 4.24.1
Then, it solved

Same issue with 4.24.3 on Catalina.

Unreal Engine 4 v. 4.22.3 don’t work with xcode 11, change xcode to 10.1 or 10.3(not sure)
if you want to use 11.3 - use 4.24 UE

That’s right. Which XCode version to be used can be checked in the Release Notes.
Unreal Engine 4.22 Release Notes: https://docs.unrealengine.com/en-US/…_22/index.html

Choose/Switch XCode version used by unreal with MacOS terminal command:
sudo xcode-select -switch /PathToXCodeVersion/Contents/Developer

for example:
sudo xcode-select -switch /Applications/XCode10.1/Xcode.app/Contents/Developer.

You can also select which XCode version to use via XCode -> Preferences -> Locations and then selecting from the dropdown. You need to have reinstalled the old toolchain first though. Check the sticky at the top of this forum for instructions.

i was able to fix this error by updating to 4.24

To use x-code in unreal engine, just open x-code and then open x-code preferences and then go to location tab and then click on command line tool and select latest version available

This actually worked for me and most of x-code users will find this useful

If this did’nt worked then the problem is something else

2 Likes