Xcode was not detected on this Mac

Hello. I installed Unreal Engine 4 on macos today.

When I run the editor, the following message is displayed.
285648-
I have installed xcode. even reinstalled it.

Please let me know how to solve this message.

Having the same issue, can’t seem to find a fix

I had the same despite Xcode being installed. It happened because I hadn’t accepted the Apple Developer Program License Agreement in the [Apple Developer Portal][1]

If you login into the portal with your Apple username and password you should see this:

PS You won’t see this message if you don’t have a Apple Developer Program membership (You need one to be able to build for MacOS/iOS)

You also need to point to the correct Xcode install run xcode-select -r in a terminal to reset it to the default

On Mac, I didn’t have xcode installed when I installed unreal. So I had to install xcode and then uninstall and reinstall unreal. It seems that xcode needs to be installed before you install unreal.

Hi! I have the same problem and hope to get here some help…I am not developer and I’ve just installed UE because I wanted to use it for architecture/design not games. So I have no knoledge about Xcode and those answers above are not really helpfull for me…is there any way to solve the problem with easy steps and not to have to learn for ages about Xcode and so on…I would really appreciate your help.
Thank you in advance and nice regards!

having the same issue, it be great if the message could go a little further in explaining step by step what to do. I have no idea how to "set active developer to current Xcode installation " …

maybe open your .uproject with text editor and change:

“Name”: “XCodeSourceCodeAccess”,
“Enabled”: false

to

“Name”: “XCodeSourceCodeAccess”,
“Enabled”: true