XCode Project "User Header Search Path" error

Create a default project and open it with xcode.

Hi vrqq,

I made a new code project and added a new code Actor class to the project. When I right-clicked on the GameFramework/Actor.h include in Xcode and selected the option to go to the definition, I saw a question mark briefly appear on the screen, and the second time it opened up the Actor.h file as expected. Is that what you are seeing happen?

I’m having this same issue. Xcode 8.2.1, UE 4.15.

The space in “Epic Games” is forcing a second line in the Header Search Paths within Build Settings. I stumbled across this when I was getting fed up with the complete lack of autocomplete within Xcode. Whatever template parser (I can’t find it) is used to generate the project clearly can’t handle spaces. I suspect this is what’s bunging up the autocomplete on MacOS.

Hi vrqq and wallyfoo,

Thank you for the information that you both provided. I was able to see the issue that you described, and have entered UE-42234 to have it investigated further. It appears that this issue can be avoided for now if you make sure the Engine is installed so that there are no spaces in the install location path.

, thanks for taking the time to look into this. I’ve posted my solution to the issue below. It seems to work until Epic can remove the space in their folder name within the installer. : ]

As mentions above, the space in “Epic Games” kills the search path. Problem is that simply changing the name of the folder , /Users/Shared/Epic Games to EpicGames kills the launcher – it stops being able to find the path, obviously.

So, fire up your Terminal, cd /Users/Shared.

mv Epic\ Games EpicGames
ln -s EpicGames Epic\ Games

Has to be a symlink and not a Finder alias, but this seems to satisfy both the Epic Games Launcher and Xcode. My test project is merrily indexing all the files it once was no longer able to find. This should work until Epic gets around to removing the space from their folder path within their own installer.

I can confirm that I am experiencing the same bug using Unreal Engine 4.15, Xcode 8.2.1 and El Capitan 10.11.16.
I can also confirm that @wallyfoo fix works. After renaming my engine folder and creating the system link, I deleted my xcode project and regenerated it by right-clicking the .uproject “Services->Generate Xcode Project”. Opening the newly generated xcode project, the paths in “User Header Search Paths” where properly set and my auto completion works.

Thank you! Note: you may also need to “Refresh Xcode Project” in the Unreal editor after making this change.

ive just experienced this bug… and it is quite weird as I had done a different project in the same engine location using xcode and c++ and it worked… i was at a tutorial class today and tried to make a new project using purely c++ and xcode could not find coreminimal.h , upon investigating we found the spaces, but doing the sys link did not fix it as we couldnt even run ue4 after (tried all the steps mentioned above), installing a clean version of ue4 in a folder without the spaces at “/Epic Games/” fixed it

Hi ,

Sorry to hear that you were affected by this. I checked the status of the ticket that I had entered for this, and it looks like it is expected to be fixed in 4.18.

My internet was slow so I was hesitant to make any changes that would cost me hours. Just so that everyone else knows, If you delete your engine and then add it back, as soon as you click on Install it will prompt you for the location. Remove the space in that path and you should be all good.

I ran into the same problem where the symlink didn’t work for me. I’m currently in the process of installing the engine again without a space in the location path.

Still not fixed as of 5.0.3.

Everyone who has written any code of note knows NEVER PUT SPACES in folder names. Why has Epic not resolved this very simple issue?