Xcode project settings don't allow launching from browser

While this might be a design decision and not a bug, it’s likely to confuse new users, since it requires extra non-obvious steps which are not necessary on Windows with Visual Studio.

To reproduce:

  1. Create a new project. It can be one of the sample ones, like CppFlying.
  2. Once you’ve run it from Xcode and built your CppFlyingEditor, close the editor and Xcode.
  3. Re-open the project browser. You’ll see the CppFlying project. Try to open it by double-clicking on it.
  4. You’ll get an error window stating The game module CppFlying could not be found. Please ensure that this module exists and that it is compiled.

This can be confusing for new users, particularly since they’ve just built it and run it from Xcode the first time around. There’s an answer here on how to change the settings so that you can actually open it without always having to go through Xcode first, but I suggest that should be the default.

For what it’s worth, you can use Product->Build for->Profiling instead of Product->Build to build Development. But yeah, I agree, it’s not ideal and may be confusing for new users, especially given it’s different from defaults in Visual Studio project.

The thing is that after the initial build, you usually want to use debug for your game. And because switching between configurations in Xcode is a multistep process, much more complicated than in Visual Studio (especially when you consider the need to browse for the app to run), we set debug as default for building/running. We discussed this and have some changes planned that should improve things (for example we plan to automate some of these steps).