Download

XCode error when compiling Programming Quick Start project

Hi!

I’m trying to work on this tutorial:

However, since I am on a Mac, I am using XCode instead of Visual Studio.

When I try to create a project, I always get this error message:

The project could not be compiled. Would you like to open it in Xcode?

Running Mono…

Setting up Mono
/Users/Shared/Epic Games/UE_4.17/Engine /Users/Shared/Epic Games/UE_4.17/Engine/Binaries/Mac
@progress push 5%
Parsing headers for QuickStartEditor
Running UnrealHeaderTool “/Users/christopherspears 1/Documents/Unreal Projects/QuickStart/QuickStart.uproject” “/Users/christopherspears 1/Documents/Unreal Projects/QuickStart/Intermediate/Build/Mac/QuickStartEditor/Development/QuickStartEditor.uhtmanifest” -LogCmds=“loginit warning, logexit warning, logdatabase error” -Unattended -WarningsAsErrors -installed
Reflection code generated for QuickStartEditor in 7.7653205 seconds
@progress pop
Performing 6 actions (8 in parallel)
[1/6] Compile SharedPCH.Engine.h
In file included from /Users/Shared/Epic Games/UE_4.17/Engine/Intermediate/Build/Mac/UE4Editor/Development/Engine/SharedPCH.Engine.h:137:
In file included from /Users/Shared/Epic Games/UE_4.17/Engine/Source/Runtime/Engine/Public/EngineSharedPCH.h:302:
Runtime/CoreUObject/Public/UObject/UnrealType.h:3277:37: error: lambda capture ‘LocalMapLayoutForCapture’ is not used -Werror,-Wunused-lambda-capture]
[LocalKeyPropForCapture, KeyPtr, LocalMapLayoutForCapture](void* NewElementKey)
^~~~~~~~~~~~~~~~~~~~~~
Runtime/CoreUObject/Public/UObject/UnrealType.h:3290:41: error: lambda capture ‘LocalMapLayoutForCapture’ is not used -Werror,-Wunused-lambda-capture]
[LocalValuePropForCapture, ValuePtr, LocalMapLayoutForCapture](void* NewElementValue)
^~~~~~~~~~~~~~~~~~~~~~
Runtime/CoreUObject/Public/UObject/UnrealType.h:3786:47: error: lambda capture ‘LocalSetLayoutForCapture’ is not used -Werror,-Wunused-lambda-capture]
[LocalElementPropForCapture, ElementToAdd, LocalSetLayoutForCapture](void* NewElement)
^~~~~~~~~~~~~~~~~~~~~~
3 errors generated.
ERROR: UBT ERROR: Failed to produce item: /Users/christopherspears 1/Documents/Unreal Projects/QuickStart/Binaries/Mac/UE4Editor-QuickStart.dylib
Total build time: 23.39 seconds (Local executor: 0.00 seconds)

I did read this:

I then tried to build the project again with XCode’s Product -> Build command, but I got the same error message again. Any advice on how to get around these errors?

Thanks!

Is version 4.17 necessary? I’d build 4.22 because of obvious reasons.

Weird. Must have been an old version left over from a previous install.

Okay. That did the trick! Thanks!