Xcode compiled editor crashes on play

Steps to replicate:

  1. Download UnrealEngine-Promoted branch from github
  2. Click Product → Build
  3. Click Product → Run
  4. Open any default project template
  5. Click Play

Result: The editor freezes eternally

Also, I have not found any real instructions on how to use a compiled editor on the mac. Any help would be greatly appreciated.


Hey Merchant-

Thanks for reporting this issue. I was able to reproduce the crash and have entered a bug report (UE-12024) for further investigation. I would suggest using the releases branches rather than promoted or master branch on GitHub as the release branches have undergone more testing and are going to be a more stable build.


Thanks , however the release branch is not much better. When launching for iPhone, it freezes as well.

Any thoughts? I’d really like to try out the deferred rendering with metal on iOS option and it says it’s only available by using the source on github.

A few things:

  1. The editor is freezing, not crashing? Since you are running in Xcode, you can break in the debugger and see where it’s frozen. Programmers will try to repro it here in Xcode, tho. Oh, actually, since the editor restarts when opening a project, you would probably want to edit the scheme and add the path to your .uproject file as the first parameter to the editor command line.

  2. What instructions for compiled editor do you need exactly? Running in Xcode? Running outside of Xcode? Etc

  3. With release, it’s freezing the same way when you launch on iPhone? That is really not expected (either is the other freeze).

  4. The deferred Metal renderer is really early and there are some things I haven’t checked in yet that will make some things work/look better. I expect 4.8 to really be where it shines.

  5. [Shh, this is a secret]. You don’t actually need to compile the editor to get the deferred renderer working. I just disabled the option in the binary build to make a bit of a barrier to entry with it, since it is so early. If you manually edit your project’s DefaultEngine.ini, set (or add) the “bSupportsMetalMRT=True” value in the [/Script/IOSRuntimeSettings.IOSRuntimeSettings] section.

  6. number 4 again! :slight_smile: