Xcode build problems

Make a BP project on Windows

Trying to get Apsalar to work via Analytics Blueprint Plugin and Apsalar Plugin, gives me this error:

LogModuleManager:Warning: ModuleManager: Unable to load module 'IOSApsalar' because the file 'C:/Program Files/Epic Games/4.8/Engine/Binaries/Win64/' was not found.

After some searching around it looks like I need to compile engine from source on Mac to make it work

After a whole lot of messing around I managed to get the engine source to build on a Mac Mini.

On the Mac Mini, if I start a new BP only project it opens and runs fine.

If I start the engine and make a new cpp project, then open the .xcodeproj file, everything looks fine and it compiles and works.

If I copy my BP project from Windows and run the “Generate Xcode Project” option from the .uproject file it makes the project file, but it appears to be missing a bunch of stuff that the cpp one had, which i figure is mostly handling the fact that there’s custom code it needs to be aware of and build.

When I open my transfered project in xcode and try build I get this error:

Rocket: No modules found to build?
! Command /Users/Shared/UnrealEngine/4.8/Engine/Build/BatchFiles/Mac/RocketBuild.sh failed with exit code 5

If I open the engine and then try to open my .uproject file, it crashes every time.

I’ve been completely stuck for days trying to get past these issues and have made very little progress.

There is little to no documentation on how to get the analytics plugins to work aside from configuring an INI file, which I have done to no avail.

Any help would be greatly appreciated.

Update 07/21/2015

After fixing the crashing,

I am now getting the following:

I’m guessing the plugin is not being compiled, how do I tell Xcode to build that plugin?

Hey -

Just to be sure you created a blueprint project on Windows and then transferred the project to a Mac machine, correct? If the project began as a Blueprint project then you will need to add code to the project through the File->Add C++ Class option inside the editor. You can then right click on the .uproject and Generate Project files. Additionally, are you able to create/convert a project without the Apsalar Plugin?


“Just to be sure…”
Correct, project was initially created on Windows then opened on Mac.

“…add code to the project through…”
What code? It’s a BP only project.

“…right click…”
That’s what I did, and when I try compile it throws that error.
There has also been an issue compiling the engine from source on a mac which is being adressed by staff which might be related - Build engine source on Mac - Programming & Scripting - Unreal Engine Forums

“…without the Apsalar Plugin?”
Without the plugin I can build and run the project fine, I can even build directly to iPad from Windows.

Hey -

To generate project files for a project there has to be a Source folder in the project directory. A BP project does not have this folder by default so custom code has to be added to the project to generate the folder. Additionally, are you able to create a code project on Windows and transfer it to Mac?

On Windows I made a copy of TappyChicken and added a new empty cpp class.

Copied the project over to the Mac.

Opened a copy of the project using the engine build I made from the git source with small modifications to stop it from crashing - Build engine source on Mac - Programming & Scripting - Unreal Engine Forums

Engine generated and compiled some code for a few minutes.

Project opened with no cpp classes listed in content browser. Compile button was available. PIE worked fine.

Opened plugin window and enabled Analytics BP and Apsalar BP, configured INI.

When I reopen the project and run it, log shows the same thing as my project - LogWorld: Bringing up level for play took: 0.011102LogVoice:Warning: Failed to - Pastebin.com

I also tried generating project files after adding the plugins. When i try to compile in xcode (build for running) it says:

Configure "BlankProgram - Mac" for running.

And it wont compile until I fix the scheme, which i have no idea what it wants me to do.

Just found the scheme switcher at the top, changed it to TappyChicken and it built and runs.

Still get the same errors about the plugins being: ‘not a file’

The plugin should be built automatically if Mac is not a blacklisted platform in .uplugin file. Perhaps the code that tries to load the plugin has the windows path hardcoded somewhere?

I’m using the ‘Analytics Blueprint Library’ and ‘IOS Apsalar Analytics Provider’ plugins that come with the engine.

If they aren’t working they should be logged as such and i’ll need to try find an alternate analytics solution.

Any suggestions for IOS analytics support would be appreciated.

Hey -

I’ve reached out to other developers for additional information. I’ll respond here to let you know when I have more info or if I have any other questions.

Hey -

I’m still trying to reproduce this on my end and just want to double check that I’m following the same steps that you are. I try creating both a code and blueprint project on Windows and copy them both to Mac. Once on the Mac I turn on the Apsalar plugin in the plugin menu and restart the editor. At this point is when you start running into errors, correct? If there are steps that I’m missing or something else you’ve done differently please let me know. Additionally, are you able to add the plugin to the project before moving the project from Windows to Mac?


Initially I had my project setup with plugins on windows then moved it which didn’t work.

Then I made a new project entirely on mac with plugins which also didn’t work.

I don’t have reliable access to a Mac to keep testing.

It also looks like I can use Google Play for IOS analytics (unconfirmed) which may work around this issue for me.