Download

Xcode and Mac (un)usability, 4.10.*

Hi,

I’m sorry if this is a rather broad request but basically developing on Mac (any OS version and hardware and any project, even the hello world tutorial) it’s basically impossible as of 4.10.*
Few problems that I’ve got and I suspect I can’t be the only one (And I’ve searched and googled everywhere, no one has got the answer for these):

- New Scheme system is (still) wrong:

There are 4 schemes and only 1 is working:


*- Debug Game *
You cannot run any standalone game version from xcode, it always complains with the following error:

"*The global shader cache file ‘/Users/Shared/UnrealEngine/4.10/Engine/GlobalShaderCache-GLSL_150_MAC.bin’ is missing.

Your application is built to load COOKED content. No COOKED content was found; This usually means you did not cook content for this build.
It also may indicate missing cooked data for a shader platform(e.g., OpenGL under Windows): Make sure your platform’s packaging settings include this Targeted RHI.

Alternatively build and run the UNCOOKED version instead.*"

Now I think there are several problems:
1) You cannot run an UNCOOKED version, or I cannot find for the life of me the way of doing it on mac. Adding default arguments to app won’t change a thing. Please explain how to run an uncooked version on MAC,every tutorial I’ve seen is either wrong or old and not applicable to Mac.
2) Even if you manage to find that file somewhere else on the operative system, it will cascade with a series of other files/assets it cannot find.
3) Even if you cook the content from the editor, it won’t fine/generate that GlobalShaderCache-GLSL_150_MAC.bin file anyway, and probably more files to come.

Now I’d like to know how anyone can have it working, I suspect it could be a path problem that only some users experience, or the Mac version is simply broken. But how can it be? Surely you won’t release something that it’s just broken?


*- Debug Game Editor *

It builds fine but then fails to launch the editor, the filename is simply wrong, is failing with:
Could not launch “UE4Editor-Mac-DebugGame”

Now the problem here is that file doesn’t exist and/or it shouldn’t be called that way, I cannot find anywhere in mono where that file should have been created, and in the Xcode scheme manager window the executable name is the game itself, not “UE4Edtiro-Mac-DebugGame” and trying to bodge the filesystem into forcing that file to appear there is very wrong and causes other catastrophic problems down the line, plus really you shouldn’t need to do that, obviously!


*- Development *

Doesn’t work same way as Debug Game.


*- Development Editor *

Works.

Moreover on every scheme UE4_build won’t build with the following error:
Setting up Mono
Building UE4Editor…
Performing full C++ include scan (building a new target)
Creating makefile for UE4Editor (no existing makefile)
Compiling with MacOSX SDK 10.11
ERROR: Rocket: No modules found to build?
Command /Users/Shared/UnrealEngine/4.10/Engine/Build/BatchFiles/Mac/RocketBuild.sh failed with exit code 5

Please can you share with us some light on this? Let us know what’s the real status of mac’s support as it’s impossible right now to use it.

Just use the launcher, it will work.


Then if you are in code… mmm, I think I get the "Debug Game " on Windows… so I not think this problems are specific to OSX… havent tried I just reverted to debug game editor IIRC is the default if you want to launch editor from xcode.

But maybe you can try go to file->cook content for… and see if that help in that case, I didnt try, I just reverted the scheme to default.

I’m not sure I understand your reply.

There are various exposed features that are simply broken, or at least this is what I want to know. Are they really broken or it’s just me?

To me it’s simply not acceptable that after so many releases the whole product it’s simply totally broken.
I don’t understand why they’ve put so much effort into revamping the xcode support for 4.10 just to make it very very very broken. Why just don’t expose the development editor on mac and say: “Look this is the only thing that will work for now”.

Just use the launcher version? do you really really need to launch from XCode? is not enought to just add C++ class? sorry I could not help more, but my mac died like 3 weeks a go because cocacola or something… but at less for what I used UE4 it worked (I remember once building all from source too, just to know) https://docs.unrealengine.com/latest/INT/Programming/Development/BuildingUnrealEngine/index.html on the OSX version.

Have you hit coock contents from file? (at less that you have no uncoocked packages I found it too in win, when trying to debug a stupid bug in my C++ code), like I said, I returned to default settings in vs 2015 cmmunity.

Yes we really need Xcode, it’s a very extensive and complex source base, it’s just not “add some c++ classes from the widget”.
We need debugging and everything else really, like hmm… A proper game development platform since the 90’s?

mmmm… guess you dont get what I say

For "- Debug Game " error. Try this, in unreal editor, go to file, then to cook contents (it will take time), then try the same build step again, it should work (a similar error is show on windows if you havent coocked the game contents before try to debug only game).

That is one way…

What I do is this, from the normal launcher, launch my project, then from file menu inside this editor open the ide (is one option of all there), and the default profile (development editor) run for mac, it will launch another UE instance controlled by the xcode, so you can close the one that launched the IDE before, here you can test and hot load from the compile in the editor, if you need to add breakpints, add them in your code.

If you are asked to build a engine, say yes.

Also make sure you can follow this https://docs.unrealengine.com/latest/INT/Programming/Development/BuildingUnrealEngine/index.html or try this https://www.youtube.com/watch?v=ydcukgaeUFc

I have no mac anymore but I remember that it worked, so GL && HF, hope if you have still having problems, some other one can join the talk :).

That’s exactly what I’ve described that’s not working. At all.
It will spat out that error I’ve quoted in my original messages, plus all countless alternatives that we’ve tried.

If you read my message, this is the only configuration that works BUT you cannot set reliable breakpoints or watches in release, and you stepping into the code it’s an adventure. You can’t work like that.

As said, nothing stated in the original documentation works, and documentation on Mac and 4.10 is lacking or wrong.

Anyways, thank you for trying to help! Appreciate it.

mmmm… if cooking is what is failing from the file->cook contents is failing, try this

Cooking doesn’t fail, it thinks it cooked fine but… It just doesn’t produce the right files, or in the right path, or something else…

Well, today I installed UE4 in a friend mac with this spec

OSX 10.10.5 (14F1021)
Xcode Version 7.2 (7C68)
Just installed launcher and installed Version: 4.10.1-2791327+++depot+UE4-Releases+4.10

Started a flying C++ template, did open Xcode and hit play button, it ended launching the second UE editor run by XCode.

If you are building from source? guess that will be another history… but at less try with the launcher…

That is what I can report :).

Hello,

Has this issue been fixed or resolved in some way? I was developing (UE4 4.10, XCode 7) for a while without any problems until recently in which my scheme decided to not work correctly and I am stuck with the same exact problem with UE4_Build. However, I can still run (DevelopmentEditor) from Xcode and everything still works, so I’m wondering what the UE4_Build error is about.

Hi,

I still don’t have any news on this and i think Epic’s silence means that mac OS is somewhat very very very very down their priorities.

Thanks tyco213 for your test but can you actually run a debug game or debug editor? As said running the DevelopmentEditor is the only scheme that works but it’s un-usable in any development cycle due to its slowness and the fact that it’s un-debuggable.

I will test in some hours if you want, but I dont understand, so please, ycould you write the steps I need to do? (because for me it works as I spect, so I dont get what could be wrong on your end). To play with it I have like the next 10 hours.

Have you managed to get around these problems? I’ve been dead in the water since 4.10, and 4.11 exhibited the same issues. XCode no longer can be run in debug mode and of course, on the mac, that is the only practical way to develop with hot reload usually not reflecting changes into blueprint exposed variables and functions. We are still at 4.9 due to these problems and quite concerned about never being able to move forward. I would think a lot more people would be complaining concerning UE4 C++ projects if things were as bad for everyone as they have been for me. Anyone else stuck at 4.9 with C++ projects on Mac?

This is going to be particularly important with the inclusion of Metal in 4.11+. We really do want to move forward.