XBox Gamepad Problem UMG 4.14

Please, we need help to find a workaround for a problem we are experiencing with the gamepad since we updated from 4.12 to the version 4.14.

We have an UMG menu where you can navigate using your left thumb stick up and down.
This was scripted in the tick, checking the Input Analog Stick State for the Y axis as seen in the image:


This menu has some checkboxes that you could check and uncheck with the button A if they had focus. What we were doing was to SetKeyboardFocus to the proper checkbox while you navigate up and down, so you could press “A” and it toggles the state of the current checkbox.

The problem is that now, whenever you use the SetKeyboardFocus node, the analog stick state value gets 0 as result in both axis. You can still check and uncheck the checkboxes, but the sticks are not receiving inputs so you are stuck on that checkbox forever.

Please, is someone experiencing the same problem? Is there anything am I missing?

Summary: SetKeyboardInput disables GetAnalogStickState node.


Maybe a long shot, but are you using the left thumbstick for something else in your game, like moving a character? If so, you’re probably getting the Axis Values from the left thumbstick somewhere. From there you can store the Axis Value in a variable, and use that variable instad of GetInputAnalogStickState.

I have just tried that, but not even the character is receiving the stick input once I SetKeyboardFocus() to a widget. Thanks for your reply though :frowning:

I have just noticed that is not only the gamepad but also the keyboard stops working when I set focus to a widget manually

I have the same problem, I updated to 4.14 and now it doesn´t works. Any idea?

Have you tried the SetUserFocus node instead of SetKeyboardFocus?