Download

x360ce - anyone got it working?

Hi,
Well, I’m still struggling with getting the Logitech G27 Steering Wheel to work in UE4. I’ve used Kablammyman’s code to get it working in a C++ project, but there are missing pieces…and a weird crash bug. It works though, mostly.
But what I would REALLY love to see are the options in the project settings to just use the wheel for control inputs. You know, the perfect solution for slackers like me that can’t code.
Well, we had done a project in the past (UDK era) using the x360ce emulator. So I tired it. I tried it because it’s a 1-off project and not going to be sold or distributed. It’s not a game…but it’s still a simulator.
Anyway, it ALMOST works. I mean, the gas and brake work perfectly! But I can only get UE4 to use the stick inputs for the steering…meaning, no float values from the wheel. So it’s just like pressing the left and right button: full left or full right.
the funny thing is, I can read the axis value (float), but can’t get it to work with the input correctly.
Has anyone successfully used the x360ce emulator?

I was able to get an off-brand wired PS3 controller to work just fine with X360CE, mapped to the Xbox controller. Everything worked fine, thumbsticks included. I haven’t tried it with any other controller however, like a steering wheel like you’ve mentioned.

That’s the weird thing. It IS working really. I can print the value of Gamepad Left X and it’ll give me that float value. But, in project settings, if I chose Gamepad Axis X for my Move Right (or left), it does not work. So I know I’m reading the value from the axis, I just can’t get it to work. The only thing I have gotten to work for steering is the Left Stick (Left and Right), which is hard left and hard right (non-float).
So, is this a wheel issue or is it the game’s controller not wanting to use a float value for the steering? I mean, the input is a float, so why won’t it use the Gamepad Left X for steering?

Update: I got it working. I had to create a new Axis Map in the project settings. I guess it didn’t work when mapped to the default Move Right because I kept the keyboard bindings on it and maybe that makes that happen? Anyway, I made a new “Steering” input on the Axis Mapping and it works fine.
Looks like this will be my solution, though I’m unhappy about it. I’d rather see native support for wheel controllers.