Wwise UE4 implementation: Failing to build


After several attempts, I seem to be completely unable to get a functional UE4 build out of Visual Studio, following these instructions:

Completely removing UE4 before retrying still failed, but gave me different errors. The frustrating this is that searching these bugs rarely yield any results. Current errors:

  • error C1083: Cannot open include file: ‘AkDefaultIOHookDeferred.h’: No such directory. (This one is repeated 14 times.)

  • error: Failed to produce item E:\08_UnrealStuff\UnrealEngine\Engine\Intermediate\Build\UE4Editor\Development\EU4Editor-UnrealEd.lib

  • error MSB3073: The command “…\Build\BatchFiles\Build.bat UE4Editor Win64 Development -waitmutex” exited with code -1.

I have tried this several times, each time trying account for the possible ways I’m misunderstanding the instructions, but to no avail. Some context on my skill level: I’m a sound designer for games. I’ve dabbled in game design and am not 100% ignorant of UE4, but I’m very beginner in that area and its technical workings. I’m trying to get Wwise to link to Unreal for a project and I’ve already spent a day and a half on this. Til this point, I’ve only used Wwise with Unity, but I like Unreal’s development workflow. Until this moment, I loved how user-friendly it was.

Any manner of help is appreciated. This is madness.

Did you make sure you copied all the necessary files in step 3? AkDefaultIOHookDeferred.h should be found in \Source\ThirdParty\Audiokinetic\samples\SoundEngine\Win32

If it is not there, make sure you copy all the files and folders found in \SDK\samples\SoundEngine to \Source\ThirdParty\Audiokinetic\samples\SoundEngine

Thanks! I did a clean install of Wwise and made extra sure to check when you mentioned. It worked. Thank you!

Now to find out how to get Unreal to utilize said Wwise events. :stuck_out_tongue: