Download

Wwise and 4.23 on Mac - no sound when packaged

The Wwise forums are completely useless so I thought I’d try here…

I went back to UE 4.23 because later Wwise versions and 4.24 were not working well together at all. At first, all seemed to work fine, (Wwise: 2019.1.4.7065, UE: 4.23.0), the sounds trigger fine in editor when ‘play’ is selected, and also when ‘Standalone Game’ is selected. (the game uses a First Person C++ template)

When the game is packaged however, no Wwise sounds play, only the sounds saved + spawned from within Unreal play.

Stuff I’ve tried:
Under project - packaging, ‘additional non asset directories’ including Wwise Audio
Packaging for ‘development’ and for ‘shipping’
Randomly putting more Wwise related files into Wwise Audio folder, I was kinda just doing anything at this point

The soundbanks are set up correctly otherwise I would not get sound in the editor when testing…

Building for Mac.
The actual implementation of the Wwise event was done with BP, but that should be fine right?

Thanks in advance for any help, lovely community. Hoping that someone else has gone through this and has a fix