Wrong Visual Studio 14 version in .sln

in .sln file there is set wrong variable VisualStudioVersion thats causing Visual Studio Selector choose wrong visual studio

In unreal generated sln file is this line:

VisualStudioVersion = 14.0.22310.1

In newly created VS14 project is this line:

VisualStudioVersion = 

When i change UE generated line to the second one selector will choose correct version of visual studio.
Bug happens in both compiled and downloaded UE. I have installed Visual Studio 12 and Visual Studio 14 Professional SP1 (+ maybe some others older but problem is that VS12 is opened insted of VS14)

Hi ,

I ran some tests with this, and unfortunately I was unable to see the same results that you described. When I checked the .sln files, they showed values similar to what your first variable showed (ie. they were all prior to). I then installed SP1 in VS 14, rebooted the PC, and made a new UE4 project. When I checked the new .sln, it showed the correct value (), and opening the file opened VS 14. I also tried opening several previously-existing .sln files, and they all opened in VS 14.

I don’t think this will help, since it will still provide the previous value, but try generating project files again and then open the .sln to see what version of VS it opens in. What version of Windows are you using?

Hi ,
I have no idea what happend between yesterday and today, but now even with 14.0.22310.1 version Visual Studio Selector Opening VS14 like it should. Wierd i was ignoring opening of VS12 for about week before reporting and over night after report it fix it self. I am using Win 7 btw.
I think this can be closed it was some VS Selector bug, because with same sln file it opening right Visual Studio right now.
Thanks for testing it and trying to help anyway :]


I’ll go ahead and close this post for now since neither one of us can reproduce the issue any longer. If you happen to notice this happening again, please let us know and we can try to investigate further.