Download

Wrong transform of character when recording sequence

I’ve tried posting this in the answer hub but never got any answers.
https://answers.unrealengine.com/questions/587437/wrong-transform-of-character-when-recording-sequen.html

I’ve been trying to record with the Sequence Recorder but end up with our character laying on it’s back. The clothes he is wearing that are skeletal mesh components with “Set master pose component” to the mesh of the character have the right rotation but the character is laying down but is animating.

I have tried multiple settings and even changed the rotation of the root bone in the resulting animation asset but nothing helps.

It used to work fine in 4.14 but I have done some smaller changes since then so I’m not sure if updating or changes caused it.

Also the gun is no longer animating at all, it’s stuck in the wrong position, that used to work as well.

Any idea what might be causing this and how I can fix it?

I’ll go ahead and bump this. I can’t figure this out and I’m completely stuck. Anyone have a clue what might be causing this? :slight_smile:

There’s not really enough information to say much. You can start by removing the animation blueprint (setting it to None) temporarily to see if it’s caused by blueprints or the skeleton/mesh.

Hi,
this problem happened to me before, I don’t remember exactly how I did fix it , the only thing I remember is that it was caused by a misuse of the skeleton :slight_smile: Check your skeleton.

Thank you. I have both tried removing the anim blueprint and imported the skeletal mesh again both with it’s own skeleton and selecting the default UE one when importing and it still happens.
What I don’t get is that the character works just fine when playing and in editor, I only see this issue after recording a sequence.

Yeah I think it’s caused by the mesh/skeleton but I can’t seem to get it to work. I’ll examine the skeleton and see if I can figure it out. Thanks for helping!

I had a similar problem like this once. I’d set the transform of my character in the viewport to rotate -90 degrees in the Z direction so it’d line up straight, but the character would always act as if I never applied this rotation.

Do you have this node in your blueprint?

If so, make sure it’s the last thing to execute on the construction script. Rearranging the order of nodes to place this last solved my issue.

Thank you! I haven’t done any rotation by hand but it seem to be affected by something similar. Probably I screwed up the actual skeleton/mesh I’m importing. It keeps happening even without the blueprint and even when I just import the skeletal mesh again in a different folder so it’s not the blueprint causing it at least.

Yo you have to open the animation of the recorded scene and set the Root Motion from Ref Pose to Zero. (its on the left side)

Acanku this solved the issue. Thank you!

If anyone out there is having this problem and the suggested solution didn’t work for you - in the sequence recorder window, I just unchecked ‘record in world space’ and that fixed it for me