Wrong level Sequence render

Hi all, I’ve set up three different level sequences to show off three distinct, separate spaces in my building. I’m aiming to render out a movie.

When I first made them and did a test render of each, all three rendered fine. But now I can’t seem to get either of the first two sequences to render again. Whichever one I open up and have active, it always renders the one I made most recently. I select the Camera Cut and have the camera icon highlighted, so it looks active in the main view, plays okay in the viewport, but then hitting Render Movie always starts rendering the third sequence.

I’ve even added all three into a master Level Sequence to combine them, but it still just renders the last of the three.

I’m using Camera Cuts. My start and end timecodes are fine (the green and red lines). There’s no scripting messing with it.

What am I doing wrong? How do I tell it which of the three sequences to render?

I find i have to close the render movie setting panel, then re open it each time I open a new sequencer
I also only render out each sequence separately and just put them together in premiere or after effects

Thanks YuuJin. That’s what I was hoping to do - unfortunately I couldn’t go back and render sequences I’d already set up, and it seems crazy to be limited to only rendering a sequence the moment you create it!

My solution in the end was to copy paste every single camera and keyframe into the one sequence that was rendering, as there was no way of getting back to old ones :frowning:

Is it possible that you’re playing that first/wrong sequence in blueprint or have the level sequence actor on autoplay?

I’m not using Blueprints at all for this project, so that shouldn’t be an issue. I don’t believe I have the sequence on autoplay - where would I find the setting to check? I could get all three sequences to play in the editor window with no problem. It’s just the render to file button always picks the last sequence, and there doesn’t seem to be anything in the render palette to tell it which sequence to use.

(As it is, I can’t actually open any of my Unreal Projects right now, including this one. Currently reinstalling UE 4.22.3 in the hopes that it fixes it…)

I have not only this but sometimes it decides to render from a player start that doesn’t exist, deleting cameras and sequences is worse as it still thinks they are there and records from ones no longer there and puts up errors reopening about missing sequences and objects,
I want to know how to purge my level of stuff I removed.
I am not building a game, just rendering videos using assets and imports.

I’m having this issue too. The behavior isn’t consistent at all. Sometimes I’ll render out frames fine but at a certain point it just stops rendering from the camera and renders from an arbitrary location at a weird angle possibly from the origin. Setting up everything from scratch doesn’t fix the issue either. This issue in Answer hub seems related but it doesn’t work for me. I’ve always had a Camera Cuts track setup properly. Sequencer Not Rendering Selected Camera - UE4 AnswerHub If you ever figured this out please let me know. There’s a looming deadline for me and I dead in the water.

Same Issue, totally annoying and putting huge delays in my project timeline! Now I created a new master sequence, and it’s rendering old sequences, mixed with new sequences. I’ve even put a frame range to render, and it starts rendering a loop of old sequences, no level blueprint.

What worked for me (Ue5):

  • Change Levels to Always Load (Windows > Levels>
  • Clicked on Blueprint. Added a node with the Camera Actor (this was the one that worked). Not a gamedev but I imagine it’s telling the game this is the level and this is the camera. Probably if it’s black it means there is no camera node in the blueprint of the level.
  • Delete all additional unused master sequences.
  • Delete all other levels.
  • Make the current level the default (Project Settings > Maps > Default startup level).
  • Click on the plus sign of the Camera Cut (Even if you have a camera already) > This Sequence > (Select the Camera). A thumbnail should appear with the sequence.