Wrong Icon for Packaged Game


I’m having an issue where my packaged project is not showing the application icon which I defined in the project settings.

I’ve defined the icon in Project Settings > Packaging > Windows:

screenshot: 267494-image-957.png

As you can see from the below screenshot, the package icon is the default unreal icon and not the one which I defined in the project settings:


I didn’t have this issue before 4.21 so I’m wondering if this is a bug related to 4.21.2?

Any help would be much appreciated. Thank you.

I think it’s kind off a windows bug or something. Had the same problem with a recently packaged project with 4.20. It wouldn’t even show the icon in windows explorer. After copying the packaged project to a USB it fixed the issue (might work with moving it to a different location on the local drive)

@HulpeSergiu - I found the solution.

This only happens when adding a custom splash PNG in the packaging settings. The icon works when I remove this and revert to the default Splash.

I presume this is a bug.